New file detection sucks + files not being overwritten...

  • I have worked with developing a project that will eventually run on PyCom hardware since late 2019. There is one incredibly annoying issue that bugs me every time, and that I can not find a solution to. I have the latest version of Visual Studio Code, the latest firmware version, tried re-flashing and factory wiping devices, switched USB-port, switched computers, switched between Mac and PC, replaced USB-cable and expansion board. Nothing works.

    The project is starting to get heavy with 100+ files. It is super annoying that every time I make a small change, your software can not detect file changes and has to upload all files, which takes more than 5 minutes. I want to be able to develop with a somewhat acceptable speed and only replace the files that I have updated. The "Failed to read project status, uploading all files" is displayed on at least 90-95% on all my file uploads, even though I have switched everything that I can possibly switched (I have also tried with the Atom plugin, but I find it even laggier).

    That is not the end, sadly. What's even worse is that after the device has uploaded "all files", files don't get overwritten properly. Static content such as HTML files does not update to the new version of it, and the same goes for code. I had a function that was defined, but then commented out and removed by me. I verified that just now, but the PyCom still is stuck in an error I fixed days ago in my code.

    I have switched everything and eliminated hardware issues. I have tried old and new devices, and done everything I mentioned above. What can I do now? Any troubleshooting? I assume that this is something with your plugin. Products have a deadline, and PyComs are designed for developing products. But deadlines can't be met if an official plugin slows everything down for you.

  • We are not using the serial connection, we are using USB. But I can get back to you in a couple of days when we have a serial converter available. Thank you for the suggestion! :)

  • @techykermit In our project we also manage more than 100-120 files, and don't really see a problem in code updates. We are using Atom and not VScode as you do, but I think the codebase of the Pymakr plugin is the same. I recall that at some time back ago we had a problem which is really similar with what you describe here, but we eventually found out that the culprit was a clone FTDI USB-to-Serial Converter. When we started using an original CP2102 chip things got stable again. You said that you are using an Expansion Board, right? Could you try to access directly the Pycom board using its UART pins (TX0/RX0) and a USB-to-Serial Cable, and see if the problem persists?

Log in to reply

Pycom on Twitter