Need help upgrading modem firmware



  • When I print sqnsupgrade.info() I get:
    Your modem is in application mode. Here is the current version:
    UE5.1.0.0f
    LR5.1.1.0-46470

    Which option am I supposed to pick to upgrade the firmware for CAT-M1, since 46470 doesn't appear (and seems to be newer than the one I'm supposedly supposed to upgrade to).

    CATM1-41065.dup
    updater.elf
    upgdiff_33080-to-41065.dup
    upgdiff_39529-to-41065.dup
    upgdiff_41019-to-41065.dup


  • Global Moderator

    Hi,
    We are currently shipping modems with newer firmware than we have available.
    FIY, your modem is already a CAT-M1 firmware (LR5.xx) so you do not need to update it. If you do wish to update it, do not use the upgdiff files, as the none of the old versions match with what you currently have, you can only do a full upgrade using the CATM1-41064.dup file.
    Best,
    Gijs


Log in to reply
 

Pycom on Twitter