LTE-M GPy Spain - Attach?



  • Hi all pycom colleagues!!

    I am sure somebody in the forum can help me!

    I am using GPy to connect to LTE-M in Spain with Orange. Always when I am attaching is the same, 'SCANNING':

    SYSTEM FSM

    +--------------------------+--------------------+
    |            FSM           |        STATE       |
    +--------------------------+--------------------+
    | RRC TOP FSM              |SCANNING            |
    | RRC SEARCH FSM           |WAIT_RSSI           |
    | RRC ACTIVE FSM           |NULL                |
    | PMM PLMN FSM             |ANY_WAITCELL        |
    | EMM MAIN FSM             |NULL                |
    | EMM AUTH FSM             |NULL                |
    | EMM CONN FSM             |NULL                |
    | EMM TAU FSM              |NULL                |
    | EMM TEST FSM             |NULL                |
    | ESM BEARER FSM           |BEARER_NULL         |
    | SMS MT FSM               |IDLE                |
    | SMS MO FSM               |IDLE                |
    | HP MAIN FSM              |IDLE                |
    | HP USIM FSM              |READY               |
    | HP SMS MO FSM            |IDLE                |
    | HP SMS MT FSM            |IDLE                |
    | HP CAT FSM               |IDLE                |
    +--------------------------+--------------------+
    

    I have checked in all the forum, I have tried with different modem versions and always the same. I have tried with different Orange LTE-M suppliers, I have let the GPy during hours trying to attach...

    I have the pytrack + Gpy connected directly to my PC with USB, without external power.

    GPy version:

    """
    GPy with firmware version 1.20.2.r0
    Your modem is in application mode. Here is the current version:
    UE5.0.0.0d
    LR5.1.1.0-41065

    """

    The code I am using is:

    lte = LTE()
     lte.init()
     lte.attach(band=20, apn="att.iot") 
     print("attaching..",end='')
     while not lte.isattached():
                time.sleep_ms(500)
    
                print('.',end='')
                print(lte.send_at_cmd('AT!="fsm"'))         # get the System FSM
    print("attached!")
    
    lte.connect()
    print("connecting [##",end='')
    while not lte.isconnected():
                time.sleep_ms(500)
                print('#',end='')
                #print(lte.send_at_cmd('AT!="showphy"'))
                print(lte.send_at_cmd('AT!="fsm"'))
    print("] connected!")
    

    As you can know, I have tried everything in the attach function.

    Somebody can help me? Is it something definitely that I am doing wrong and I can not see it?

    Thanks in advance.



  • @dpoza All zeros for creg/cind is bad news. My guess is that 'orangeworld' must be the wrong APN or it needs a username/password. Try

    lte.send_at_cmd('AT+CGDCONT=1,"IP","orangeworld"')
    lte.send_at_cmd('AT+CGAUTH=1,1,"orange","orange"')
    

    Failing that, maybe try a hologram sim? They're APN seems to be 'hologram' regardless of country & they don't need a username/password?



  • @kjm said in LTE-M GPy Spain - Attach?:

    Hi @kjm , thanks for your support!

    Help me trying to analyze what is happening here:

    The response of the commands you said:
    +CREG: 0,0

    OK

    +CIND: 0,0,0,0,0
    OK

    And this command lte.send_at_cmd('AT+CGDCONT=1,"IP","orangeworld"') --> returns only 'OK'

    thanks!



  • @dpoza According to http://www.simcardspain.com/en/article/10-apn-settings-of-spanish-operators-for-configure-the-smartphone-usb-modems-3g-mobile-internet- the APN for orange in Spain is orangeworld(so lte.send_at_cmd('AT+CGDCONT=1,"IP","orangeworld"'). You might glean some info from

    sim=lte.send_at_cmd('at+creg?').split(',')[1][:1]; ser=lte.send_at_cmd('AT+cind?').split(': ')[1][2]; print('simreg =', sim, ' service =', ser)
    

    for example sim=4 means no lte coverage, sim=2 means not attached but trying to



  • Hi @jcaron , first of all, thanks a lot for the response.

    Yes, I have connected the 'wieson wstp' antenna for LTE-M in the GPy port for it correctly.
    We are trying to connect in two different areas, one in the middle of the city and the other in one of the ends of the city.

    We have tried to use the AT commands COPS and lte.ue_coverage(), but neither of them were successful for us.

    As you said, we tried also to attached without band and with others APN names (in the example I have put which one our supplier said) but the results are the same...

    Do you recommend us to change GPy firm version or a special LTE modem firm?

    Have you got another good idea to try? I would appreciate it a lot!!

    thanks!



  • @dpoza do you have an antenna connected, to the right port on the GPy? What kind of antenna?

    Do you have good coverage in your area? Have you tried moving to a different place?

    I believe there’s a command to return the list of available networks, have you tried that?

    Note that the APN you used is most certainly not the right one (Orange should let you known what APN you should use — it might be orangeworld but I’m not sure) and it’s likely it’s not the right band either (I believe you should not specify any band and it will scan them all).


Log in to reply
 

Pycom on Twitter