Pygate debug messages over WLAN AP



  • Hello all,

    I was wondering, is it possible to get the debug output for the Pygate through the LoPy4's WLAN AP?

    I tried, and I get prints over the AP while the LoPy4 is connecting to the Ethernet and getting the RTC sync, but once the Pygate initializes, the prints stop. The Pygate however turns on its green LED and works just fine. This is the output:

    Connecting to 192.168.4.1...
      Starting LoRaWAN concentrator
    Connecting to the Internet via Ethernet....................... OK
    Syncing RTC via ntp..... OK
    
    Pycom MicroPython 1.20.2.rc10 [v1.11-b2436d4] on 2020-07-01; LoPy4 with ESP32
    Type "help()" for more information.
    >>>
    >>>
    

    So I don't get disconnected from the AP, the REPL still works, but the debug messages don't appear. These can only be observed when connected over serial.

    Any input is appreciated.

    Best,

    Dan



  • @Gijs Yes! Tested rc11 yesterday and it worked just fine. Thx!


  • Global Moderator

    Hi
    Yes, the issue was that the messages were printed only to UART because we used a different method. In the new firmware, we used a different method, making the logs print to Telnet as well! Let me know if it works for you



  • @thinginnovations hello, thank you for the recommendation! As I have never set up a web server, do you have any code you could share with this (specifically for the Pygate)? If not, I understand. Thanks!

    EDIT: I just noticed Pycom has released a new firmware for the Pygate that includes "Pygate debug messages are printed to telnet". See: https://forum.pycom.io/topic/6289/new-release-candidate-1-20-2-rc11-for-pygate

    Will check this out!



  • Yes it is possible, see MicroWebsrv2

    Had something similar running on mine but as there isn't any interface from the Lopy4/WiPy to the Pygate to get stats it wasn't very effective fro anything other than setting up the config and restarting the gateway packet forwarder.

    Andrew



Pycom on Twitter