Pymakr does not find my board



  • Hello,

    I am using Windows 10 and the Lopy4, I have already installed nodejs and pymakr to be used in Vscode but when I hit the command to list the serial ports my board is not found. I know the board is ok as I can connect to the board using Teraterm a client for serial connections and run some
    commands. What can I do to fix that?



  • @d-alvrzx It is working right now, thank you. Although I thought FTDI was the manufacturer of my cable it was Digi International indeed.



  • Yes, the same thing happened to me. I was using a "Prolific" serial cable, and had to add the manufacturer name to autoconnect comport manufacturers. You can find the manufacturer of your cable under Device Manager.

    When you add the new manufacturer within Atom, it will look like this: bceef213-1db4-48f3-8574-d9b4639529d3-image.png

    Or in VSCode: 9d176a32-dbaf-4ba3-9712-ca3ea751b4a5-image.png



  • I think you have to change a setting under All commands -> Pymakr > Global Settings. I think I've had some similar issue with my PC at work, which uses Win 7 and VSC.

    Can you tell me, what is written under autoconnect_comport_manufacturers in the pymakr.json, which gets opened after you select the global settings?

    Tomorrow, I can check the settings at my windows PC at work.

    And welcome to the Forum btw!


Log in to reply
 

Pycom on Twitter