Battery Charger on the Expansion Board v2



  • Hi

    I am trying to charge my LiPo 500mA battery via the expansion board. When I connect the expansion board to the battery though, the CHG light doesnt light up. How do I know its charging? The expansion board is connected to the laptop via microUSB.

    Is there a step missing?

    Brad


  • Banned

    This post is deleted!


  • @dalecousins thanks so much for this - its a confirmation for me. Last night I tried to charge the battery through another mechnism and found the same thing - once I connected it back up again it was fine. Apparently (I found this out in another post) they havent implemented the deep sleep function in the firmware / API and therefore when I connected up my solar, the battery was draining a LOT faster than I originally expected and the solar couldnt recharge the battery fast enough, and therefore the battery drained too low. Also, FYI, deint the WIFI doesnt actually power it down and therefore will drain the battery quickly too. My solution is now on hold until these things are sorted out.



  • hi i had this problem for me was the lipo battery had discharged beyond its minimum capacity and as such will not be charged for safety. i had to use a dedicated lipo charger to bring the voltage back up and now it will charge on the expansion board.


  • Pybytes Beta

    @bradnz Did you change jumpers on the expansion board? The CHG jumper should be enabled.
    It seems to me you did it right.
    When I'am doing the same thing (USB to Laptop and LiPo connected), the CHG LED is on until battery is charged.



  • I cant. I have tried everything, uploading a JPG, JPEG, GIF, all undersize, and even copied the file to a word document and writing to PDF and they all error, either no permissions, or unsupported format!.

    Imagine, though, just a expansion board with a sipy plugged into it, a LIPO battery connected to it and a usb cable running to my laptop. Thats all there is to it. I thought I might have had to enable something, but apparently not.

    Any suggestions?


  • Pybytes Beta

    I should work like that.
    I also using this and everything works fine.
    Can you upload a photo of the construction you made?


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.