Gpy with Hologram sim will not attach to LTE



  • We were setting up a new GPy starting yesterday with a new Gpy and new hologram sim. Went through the pybytes configuration the same as 3-4 times in the past, but this time, we cannot, now after 20+ manhours of crushing, get the Gpy (or another Fpy for that matter) to connect and attach via LTE to pybytes. We can connect via wifi, but not LTE.

    We wrote some routines to read back modem responses to AT commands and it looks like the modem just is not being recognised. We even went backwards through a couple of firmware revisions, but no dice.

    I would appreciate any help.

    Thanks.


  • Global Moderator

    It might be related to this: https://forum.pycom.io/topic/6514/vodafone-sim-in-spain-not-working-solved-wrong-dns-sever ? I cannot be certain why it is now fixed, so if you run into the issue again let me know!

    Gijs



  • @Gijs For whatever reason, the exact same procedure that I was testing and failing last week is working today. I have successfully connected the new Gpy with a new hologram sim twice now with different Pybytes credentials. I have no idea why it wasn't working last week, This is the same code and the same procedure that I was using last week.


  • Global Moderator

    If you post the logs here, we can see where the connection goes wrong, also, are you able to connect to the LTE network without pybytes?

    Sorry, you were correct, the pybytes debug level should be 0-6, but setting it to 99 will definitely print all the logs (if we add more levels in the future for example). Setting 0 will still print some pybytes logs, but not all of them. They can be used to follow the process without staring at a blank REPL

    Gijs



  • I do have that set. thought I was under the impression that it should be pycom.nvs_set('pybytes_debug', [0-6])??

    on my one device that can connect to correctly, I get 100x too much information that I do not understand, but it does show that I connect via LTE through hologram to PyBytes.

    I cannot seem to able to turn off diagnostics messages... I have tried both pycom.nvs_set('pybytes_debug', False) and pycom.nvs_set('pybytes_debug', 0) and reflashed my program, but I still get a plethora of diagnostics data.

    How do I turn it off?


  • Global Moderator

    Sorry I did not respond, I do want to help, but sometimes I might miss things.

    Concerning the pybytes activation, could you try setting
    import pycom; pycom.nvs_set('pybytes_debug', 99) to give a more extensive Pybytes debug.

    Edit: True should be more than 6
    Gijs



  • This is still a problem for us and we could use some help. We cannot get any new Pycom Gpy to attach via the hologram sims to the Pycom Pybytes network, even though our original unit with a hologram sim and the same program attaches just fine.

    Its very sad that noone that works for Pycom wants to reach out to help.



  • I have now completely re-activated and flashed the GPy again, but this time did not load any program and after resetting the GPy, it still hangs on the initial watchdog with no program and whatever pybytes_config.json file it initialize with.

    I am only setting up an LTE connection in the provisioning to hologram with band 4, carrier standard, and CID 3. These are the same settings that I have been using for months.



  • I do not get any error message at all.

    I had a previously working system before I shorted it out. So I went through the process of provisioning a new hologram sim (the 4th one now) and activating a new gpy the Firmware update tool, completely erasing the Gpy to the point that then I connect it back to VSCode I immediately get a REPL (meaning there is no program or pybytes_config.json file at all). I then upload my existing program that has been running, connecting to pybytes and sending data for weeks and it hangs on the watchdog.

    Reading file status
    Failed to read project status, uploading all files
    [1/6] Writing file ads1x15.py (10kb)
    [2/6] Writing file boot.py (0kb)
    [3/6] Writing file main-test.py (4kb)
    [4/6] Writing file main.py (12kb)
    [5/6] Writing file pybytes_config.json (0kb)
    [6/6] Writing file sdcard.py (9kb)
    Upload done, resetting board...
    OKets Jun  8 2016 00:22:57
    
    rst:0x7 (TG0WDT_SYS_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff8020,len:8
    load:0x3fff8028,len:2140
    ho 0 tail 12 room 4
    load:0x4009fa00,len:19760
    entry 0x400a05bc
    WMAC: 807D3A9499E8
    Firmware: 1.20.2.r0
    Pybytes: 1.5.1
    Initialized watchdog for WiFi and LTE connection with timeout 1260000 ms
    

    Here is my pybytes_config.json file:

    {
        "dump_ca": false,
        "server": "mqtt.pybytes.pycom.io",
        "ssl": false,
        "lte": {
            "apn": "hologram",
            "reset": false,
            "carrier": "standard",
            "type": "IP"
        },
        "device_id": "4ec9acdd-f8d0-4862-8623-852c4380c07b",
        "network_preferences": [
            "lte",
            "wifi"
        ],
        "ota_server": {
            "port": 443,
            "domain": "software.pycom.io"
        },
        "pybytes_autostart": true,
        "username": "admin@vsthose.com"
    }
    

    and yes, I did change the device ID in the above file to reflect my new device ID.



  • @VST-Admin said in Gpy with Hologram sim will not attach to LTE:
    looks like the modem just is not being recognised.

    Can you be a bit more specific? Is it an

    OSError: Couldn't connect to Modem!
    

    which often responds to removal of 5v supply or something else?


Log in to reply
 

Pycom on Twitter