Atom without expansion board

  • I've got a couple of lopy4s running raw lora back & forth on the bench. One of them is plugged into Atom via a pycom expansion board, so easy to check & modify my python code at that end. At the other end I tried using a generic USB to uart converter in lieu of an expansion board (I've only got one expansion board) but no joy. Does anybody know if the expansion boards do something proprietary to the usb-to-uart comms?

  • Well it's taken all day, talking to myself here. For the benefit of any poor souls trying the story is as follows.

    1. Windows invariably makes a new com for your usb-to serial device. You can see it with Windows Device manager.
    2. You need to copy the usb-to-serial device manufacturer name into the 'Autoconnect comport manufacturers' list in Atom's Global settings. Otherwise Atom will not only refuse to autoconnect it won't even show the new com as existing/available.
    3. Many usb-to-serial devices are wrongly labelled and you need to connect their Tx to the pycom device Tx instead of the Rx.

  • I put the CRO on the usb data lines. When the device first plugs in there is a 5v swing (presumably when it & windows talk to each other) but when the lopy4 resets there is only a hundred mv or so. Same result on a couple of different usb-to-serial converters. Any body know why serial data from the lopy would produce such greatly reduced amplitudes on the usb lines?

  • Still trying to get working. With a CRO I can see 2 bursts of data about a second apart on the lopy4 Tx line when I press the reset button & the Rx led on the usb-to-serial board flashes but pymakr on Atom stubbornly refuses to find the lopy, I don't even get a cursor in the repl window. The Tx line from the usb-to-serial board to the lopy4 Rx is permanently hi @ 3v3 volts.

    Can anyone suggest a trouble shoot ?

Log in to reply

Pycom on Twitter