lopy4 sleep issues



  • My latest lopy4 came with version 1.18.2.r1 firmware. It had a problem with machine.sleep(10000)

    TypeError: function takes 0 positional arguments but 1 were given
    

    but deepsleep worked with the current falling to near zero.

    When I upgraded the firmware to 1.20.0.rc13 the problem with machine.sleep(10000) is fixed but deepsleep current is 28mA.

    Does anybody know where I can get a copy of the 1.18.2.r1 firmware? I can tolerate the bug with machine.sleep but I really need deepsleep current to be lower than 28mA


  • Global Moderator

    I do not know of the difference between the firmwares, but you could use the git hash to find the exact one in the source (At least, I think that is supposed to work..)

    I believe this is the one you are looking for: https://github.com/pycom/pycom-micropython-sigfox/tree/7bc2e5cdd34b79c5fa9f493f3df831f57b0b12ce
    You can follow the instructions in the readme to compile one for yourself (check for the pybytes version, that is the one updated in this commit, among other things)

    For the actual issue, I have no clue tbh

    Gijs



  • Unreal! lopy4 with

    release='1.18.2.r1', version='v1.8.6-849-e0fb68e on 2018-11-26'
    

    deepsleeps with uA stdby current but with

    release='1.18.2.r1', version='v1.8.6-849-d6b3616 on 2019-02-22'
    

    the deepsleep current is 28mA. How is this possible?

    I really need a copy of the 2018-11-26 version. I tried https://software.pycom.io/downloads/LoPy4.html but that's the 2019-02-22 version too.

    IS there a way to get a copy of the 2018-11-26 firmware out of a lopy4?


Log in to reply
 

Pycom on Twitter