Pysense/pytrack 2X wake on pin issues



  • I've been having issues getting my pysense and pytrack (2X versions) to wake on pin via the external 6 pin header (pin #6). It doesn't seem to work on rising or falling edge. I came across this issue for not waking on accelerometer. Does the wake on pin suffer the same issue? I installed dfu v16 in that issue which didn't resolve my particular issue. I tried to add the functions for wake_on_int_pin which includes the go to sleep bits without any luck either. Has anybody been able to make the wake on pin functionality work on the 2X versions of the expansion boards?

    It looks like the original sense/track had to have pins removed to make things work correctly, is there anything like that necessary on the newer versions? I've tried a couple variations just in case but to no avail...

    Thanks,
    Chris



  • Ok sounds good. If the two issues are related I'll watch that github issue and use the machine sleep in the meantime till that gets sorted.

    Thanks,
    Chris


  • Global Moderator

    Hi,
    We are still looking into this issue, sorry for the inconvenience. On the v16, we used a different sleep mode (where we deepsleep the module and sleep the PIC on the pysense/pytrack). I would advise you to use the machine-version of the command that runs on the development module: https://docs.pycom.io/firmwareapi/pycom/machine/#machinepin_sleep_wakeuppins-mode-enable_pull

    Gijs


Log in to reply
 

Pycom on Twitter