PyMakr Plugin constantly uploads new files



  • Hi!

    We're now getting to a stage in development when this is getting really annoying. We have around 200 files in our development project, and there are many times when we have to change one variable in a JSON file and upload to the device to test.

    Most of the time, the PyMakr plugin does not detect that only one file on the device has been changed, and proceeds to upload all files, which means that we have to wait ~20 minutes to get than one single changed line of code on the device.

    And we also have no idea why this is happening. The issue seems to be different across computers - it works somewhat better on a Mac we're using. The most problematic computer is our main development computer - a Windows machine.

    It displays this 9/10 times when trying to upload to the board, even though it has not been disconnected since the last upload:

    Uploading project (main folder)... Not safe booting, disabled in settings Uploading to /flash... Reading file status Failed to read project status, uploading all files

    Here is what we have made sure and tried:

    • Tried with over 5 different USB cables and connections - both USB 2 and 3. Worked slightly better over USB-C for a while, but now it's just as bad with detecting file system changes as before.

    • Tried with different firmware versions and branches, PyCom devices, PyCom boards, and different plugin versions

    • Ensured that the device is in "Safe Boot" on each upload (we have pressed and hold the "Safe Boot"-button until the led flashed quickly)

    The only thing we can determinate is that the issue is more apparent on certain computers than others. Now, I understand that you can't really figure out what we're doing wrong, and I'd love to find out why it "failed to read project status". Is there any opportunity to read the logs of the plugin itself to see what it failes to read from the device?

    "Why can't you just use another computer" - the issue have appeared at some point on all computers we have tried with before anyways.


  • Global Moderator

    @Don-iot said in PyMakr Plugin constantly uploads new files:

    it later came back, so we pin-pointed the reason.

    Hi @Don-iot , are you able to confirm whether you had the message "Failed to read project status, uploading all files" when the problem existed? Or did you merely see that all files got uploaded, but this specific message was not printed? Maybe you don't know, after all the problem you faced was resolved, but if you happen to know, I'd be curious.



  • Updated: I have seen the same thing using USB and the Pycom expansion board and VSC for PC. However using our own board, TTL adapter and VSC for PC we got around the problem -we thought. But it later came back, so we pin-pointed the reason. The reason is that our virus program scans the files in real time, and that interferes with the creation date or something. So when we disabled the virus program, we got around the problem. @Gijs



  • @Gijs Thank you, but also please let me know if there is anything I can help with debugging, as the issue happens much less often on a Mac I am using, with Visual Studio Code.


  • Global Moderator

    I was not aware of this issue. Though I only use Pymakr on Atom, and there is no issue there. I'll let the Pymakr team know!



  • @techykermit Seems like the problem has been around in VSC for quite some time see here. Do not know if the problem or solutions could be the same, but I hope the Pycom team has more news about this.


Log in to reply
 

Pycom on Twitter