Pymakr connection timed out, REPL accessible via screen



  • I recently have not been able to get the vscode Pymakr extension to connect to my fipy mounted on a pyscan. On opening vscode, the pymakr console opens up in the integrated terminal and is able to find the fipy on serial, but consistently times out after trying to connect. Retries within the same console instance end the same. This has worked for me in the past, and only stopped working after power cycling both the board and my laptop overnight.

    I have been able to connect to the board and get a REPL prompt using the screen utility, and have done a factory reset (formatted '/flash' via said REPL) and booted into safe mode. I also updated the firmware using the Pycom Firmware Update utility and rebooted my laptop multiple times, with and without the pyscan connected over usb, with and without the board connected to an external battery.

    I'm using Macos and nvm reports that my current node version is 12.20.1. My best guess at this point would be some issue with the version of node vscode is having pymakr use or maybe the permissions on the serial device, but I am unsure on how to proceed with either. Any help would be deeply appreciated :)



  • I'm also having the same issue on VSCode.
    I can't downgrade to an earlier version.


  • Global Moderator

    Hi,
    @Nathaniel-Lord I cannot reproduce the issue on Atom 1.54.0 and Pymakr 2.1.9 (also on MacOS 11.2), could it be related to the virtual environment you are running (USB passthrough related?)



  • @Gijs I installed Atom and the Pymakr plugin in it this morning after I saw your response and it's having the same issue. I'm running MacOS 11.2 with node 14.15.4 managed by nvm.

    Here is the software I've tried:

    Atom 1.54.0
    Pymakr Atom Plugin 2.1.9

    VS Code 1.53.0
    Pymakr VS Code Plugin 1.1.8

    Is there an issue I can track to see when this issue is resolved in either Atom or VS Code?


  • Global Moderator

    Hi,
    We're working to fix this issue. In the meantime, you can use the Pymakr for Atom
    Sorry for the inconvenience



  • I am having the same issue on MacOS. I can connect via screen or other terminal, but PyMakr just times out. VS Code and PyMakr were both updated today to latest versions, which is when I started seeing the problem. Node version is 15.8.0.


Log in to reply
 

Pycom on Twitter