FiPy deepsleep methods



  • @tuftec I have the same issue. I can't get the 'deepsleep' current under 16mA. Even if i exclude everything in my code and just keep this, it doesn't go under 16mA. The same code on a LoPy does bring the current consumption down to 20uA, so it has something todo with the hardware I guess? Anybody here that knows the answer to this issue?

    import pycom
    import machine
    import time
    from network import LTE
    from network import WLAN
    wlan = WLAN()
    lte = LTE()
    time.sleep(5)
    lte.init()
    wlan.deinit()

    pycom.heartbeat(False)

    print(pycom.heartbeat_on_boot())
    print(pycom.lte_modem_en_on_boot())
    print(pycom.pybytes_on_boot())
    print(pycom.smart_config_on_boot())
    print(pycom.wdt_on_boot())
    print(pycom.wifi_on_boot())

    #colors in hexadecimal (0xRRGGBB)
    pycom.rgbled(0x00FF00) # Red
    time.sleep(1)
    machine.deepsleep(40*1000)



  • @livius yes, wifi & lte components are turned off on boot and only enabled when needed. but I am still stick at 11mA. I am thinking that there are other bits of my circuit that are consuming current (level shifting components, i/o, etc). I did find that my rs232 monitoring port is responsible for a little. After disconnecting the monitoring, I can get down to 7.5mA. Still a long way to go to get down to 10's of uA as I would expect in deepsleep.



  • do you use some of this?

    wifi_on_boot
    lte_modem_on_boot
    

    when you set it with false then you can bring it up when you really need it.


Log in to reply
 

Pycom on Twitter