updater.py not working anymore



  • After release 1.6.3b2 if we want to go back on previous firmware using updater.py it is not possible anymore. The board is accesible through pymakr on that COM port

    d:\Pycom>python update.py 1.5.0.b1-LoPy_868.tar.gz COM15

    d:\Pycom>"c:\Program Files (x86)\Pycom\Pymakr\Python27\python.exe" pyupgrade/bin/updater.py -t 1.5.0.b1-LoPy_868.tar.gz -p COM15
    Namespace(file=None, port='COM15', speed=115200, tar='1.5.0.b1-LoPy_868.tar.gz')
    Connecting...
    Exception: Failed to connect to ESP32: Timed out waiting for packet header, on line 128



  • @pascal Yes. They fixed. GO download the latest updater.py.



  • @Colateral I am having the same kind of problem, unable to update FW, and stuck in 1.5.1b1 on 2 boards, I even resetted the flash. Is it the old problem on the ESP, which was handled long time ago by flash_debug.py, and then by Pycom Firmware Update? does Pycom Firmware Update still handle this problem?



  • @daniel Yes. Stopped the LoPy board, conn. the jumper, start the board and the COM14 exists ... but running the updater is failing.
    However, we used the UI tool and upgraded again to latest 1.6.3b2... and the board is working fine
    Then we used updater to go with 1.5.0 and update was working.... the problem is that after upgrade the board led is always red and you can not connect on it. If you use the UI tool and upgrade to 1.6.3 is working and the led is blinking. This is happening only with this board.


  • administrators

    @Colateral that error usually means that the serial port selected is not the right one or that the ESP32 has not entered programming mode. Did you reset the board after connecting the jumper?



  • @daniel Version 1.1.1 I found it... but doesn't work

    d:\Pycom>"c:\Program Files (x86)\Pycom\Pymakr\Python27\python.exe" pyupgrade/bin/updater.py -t 1.5.0.b1-LoPy_868.tar.gz -p COM14 -s 115200 flash
    Connecting...........................................
    Exception: Failed to connect to ESP32: Timed out waiting for packet header, on line 157

    I used the UI version and flashed the 1.6.1.b2. Then I used the updater.py version and was working .
    However, the led is always red.



  • @Daniel The update.py that I have is form the forum: https://forum.pycom.io/topic/517/downgrading-firmware-advanced-users

    Seems that is the same package. Do you have the link for the new updater?


  • administrators

    There's a new version of the updater.py script. Please download it and try again. It still works.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.