[SOLVED] WiPy 2.0 on Pybytes?


  • Pybytes Beta

    Will WiPy 2.0 work with provisioning, installing code, firmware updates, all that? I don't yet have a 3.0.

    And I can't access my 2.0 for a few days, hence I am asking instead of trying it. As soon as I get an answer I'll either buy a 3.0 immediately or just wait til I get my 2.0 in hand.


  • Pybytes Beta

    Problem was I wasn't using 5V on VCC and the guru meditation was coming from not having enough power.


  • Pybytes Beta

    @Gijs said in WiPy 2.0 on Pybytes?:

    I believe the Wipy 2.0 should still be compatible with Pybytes. Im not sure if it will run the latest stable firmware (1.20.2.r4) reliably and allow for a lot of micropython code, because the firmware size increased somewhat since the Wipy 2 was released, but you should be able to make it work with an earlier release if the latest does not work in your application

    Well it boots up on 1.20.2.r4, but as soon as I try to initialize the WiFi I get a guru meditation. Will try an older version.

    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff8020,len:8
    load:0x3fff8028,len:2128
    load:0x4009fa00,len:19760
    entry 0x400a05bc
    WMAC: 240AC400B1B6
    Firmware: 1.20.2.r4
    Pybytes: 1.6.1
    Initialized watchdog for WiFi and LTE connection with timeout 1260000 ms
    WiFi connection established
    Connected to MQTT mqtt.pybytes.pycom.io
    Pybytes connected successfully (using the built-in pybytes library)
    Pybytes configuration read from /flash/pybytes_config.json
    Pycom MicroPython 1.20.2.r4 [v1.11-ffb0e1c] on 2021-01-12; WiPy with ESP32
    Pybytes Version: 1.6.1
    Type "help()" for more information.
    >>> print('Hello world')
    Hello world
    >>>
    
    

  • Global Moderator

    I believe the Wipy 2.0 should still be compatible with Pybytes. Im not sure if it will run the latest stable firmware (1.20.2.r4) reliably and allow for a lot of micropython code, because the firmware size increased somewhat since the Wipy 2 was released, but you should be able to make it work with an earlier release if the latest does not work in your application


  • Pybytes Beta

    Main concern is the constrained RAM and flash space for the partitions. Since the LoPy and SiPy are supported, and they have 512KB/4MB, I feel comfortable that my WiPy 2.0 with 512KB/4MB will work.

    If anyone tells me differently in the next few days though I will place the order.


Log in to reply
 

Pycom on Twitter