[SOLVED] GPy 1.0 extremely low RSRP of -21474836.00, no LTE connectivity

  • I have a GPy 1.0 that I'm trying to connect to LTE with (for the first time). I have the antenna connected to the correct port, and also checked the antenna cable using a multimeter.

    My RSRP, which i get after running


    is -21474836.00 which seems to be the smallest signed integer value with the last 2 digits cut off.

    I interpret this as there being absolutely no signal. What could be the causes of this? What can i attempt to fix this?

    heres the os.uname() output

    (sysname='GPy', nodename='GPy', release='1.20.2.r3', version='v1.11-d945d33ee on 2020-03-08', machine='GPy with ESP32', pybytes='1.3.1')

    I have attempted to find firmware updates, but couldn't find anything for GPy 1.0

    attached is my main.py with the full code im trying to run. It switches between RRC SEARCH FSM | WAIT_SCAN_DELAY and RRC SEARCH FSM | WAIT_RSSI


  • I figured out what the issue was: the SIM card was advertised to the company i work at as a "IoT Sim" which apparently does not mean NB-IoT or CAT-M1, but normal non-narrowband LTE. We have logged a complaint with the card provider and ordered a new card. I hope this helps anyone else stumbling across this thread.

    PS: can you mark topics as solved?

  • Please could you add the modem firmware you're using and which network (NB-IoT or CAT-M1) you want to attach to. Moreover, the Simcard provider / network and band would be interesting to add as well. Did you try moving locations or testing outside, and check the coverage map by the provider?

    There is troubleshooting guide available here: https://docs.pycom.io/tutorials/networks/lte/#lte-troubleshooting-guide

    Let me know

Log in to reply

Pycom on Twitter