Gpy with PyTrack can't get gps working

  • Hi all,

    I got a GPy + pytack this week and I'm having trouble getting the GPS library in the example zip to return coordinates. It always returns (none. none). I have read through the other topics on the forum but they mostly seem to be related to signal strength issues.

    The strange part is that when I do a location update in pybytes it works and shows my location correctly although maybe this is not using the GPS module?

    So things I have tried:

    • Updated gpy and pytrack firmware
    • Left unit outside in clear view of the sky for 12 hours
    • Tested with and without external antenna
    • Check the dump_nema method and messages are being displayed/processed
    • Tested some other versions of the gps library that have been forked/modified on github

    Any tips would be appreciated as I'm stumped!


  • Some further info on this.

    I have dumped the NMEA messages from the GPS to a file and I can see that the pytrack isn't picking up any satellites.

    I have tried with antenna jumper on/off, external and internal antenna, same result.

    Could the shield be defective?


Log in to reply

Pycom on Twitter