How to set dwelltime to 0 at AS923 in lopy4?

  • hello, I have a problem when sending >11 bytes payload at SF10 (AS923) my lopy is getting os error and in TTN displays "not provided". after I read it , my error occur due to dwelltime value is 1 aa1e22e8-e376-4263-b009-dc80079b7a81-image.png.

    How to set dwelltime to 0?, so I can send more data, and can reach DR1 and DR0

  • @Gusti-Made-Arya-Wijaya Start by checking the TTN logs for downlinks. I don’t remember if they show MAC commands (and their contents), but if they do it’s probably the easiest.

    Next option is to check if your gateway includes such logs, though I don’t remember if MAC commands are part of the encrypted data in which case you wouldn’t be able to see them.

    On the LoPy itself IIRC if you want to see those you would need to recompile your own firmware after adding traces in the relevant places. I don’t think there’s an off-the-shelf way of getting that info from micropython (someone please correct me if I’m wrong).

  • @jcaron how to check the network sends a TxParamSetupReq MAC command to the device? I'm using TTN network server, Kerlink Gateway, and lopy4

  • @Gusti-Made-Arya-Wijaya You would need to check if the network sends a TxParamSetupReq MAC command to the device, and if so, what the value of the UplinkDwellTime bit is.

    Then either TTN sends UplinkDwellTime=0 and the LoPy does not take it into account, or is sends UplinkDwellTime=1 or no TxParamSetupReq at all, and then it would be the other device which is not compliant.

    Note that it sometimes takes a few exchanges after a join to get a full config, if the network needs to send several MAC commands it may need to wait for as many uplinks to send the MAC command in response.

    So if you just do join - send it may be normal that on that first send it doesn't work.

  • @jcaron thanks for reply. but I've test another lorawan end node (ursalink) and it can send 33 bytes payload at SF10, so this node work with dwelltime = 0.
    tes sf10ursalink.JPG

    why lopy4 can't do that?

  • @Gusti-Made-Arya-Wijaya The dwell time configuration is decided by the network, which sends it via the TxParamSetupReq MAC command. The default is that dwell time is enabled until the network says otherwise.

    So it would require TTN to send configuration with UplinkDwellTime=0. Not sure this is possible, it may depend on the specific country or something similar.

Log in to reply

Pycom on Twitter