Nano Gateway on FiPy for AS923 Frequency Plan



  • Hello there,

    I was trying to implement a nano gateway on a FiPy device for the AS923 Frequency Plan. Although the gateway is online on The Things Stack and is able to receive packets from my LoRa end devices, the packets are not being forwarded to the end device section of my application in the The Things Stack console.

    I tried a similar nano gateway implementation for the EU868 Frequency Plan and found that the data packets were received at the end device section successfully.

    Although the documentation clearly highlights that the source code in the repository will only work for EU868 and US915, I would still like to make the code work AS923 as well.

    Any help is appreciated.

    Wong



  • @Gijs
    Hi, sorry for being tardy with my reply.

    I have finally sorted out the problem. It was due to the enabled frame counter reset blocking in the settings of the end devices. The frame counter reset blocking can be disabled under general settings/network layer/ advanced mac settings under the end device console.

    By the way, can you please confirm if the following network layer settings are correct for FiPy?

    LoRaWAN version: MAC V1.0.2

    Regional Parameter version: PHY V1.0.2 REV A

    I have unfortunately not been able to get ADR to work on The Things Stack under the AS923 Frequency Plan. I believe it could be due to the wrong regional parameter version. Can you please kindly help me confirm with a simple test by bumping some data packets to a gateway connected to The Things Stack on your end to check if the ADR is working?
    In my own test using the Things Stack, I also noticed that the AdrACKCounter is incremented by 1 only after 7 transmissions instead of after every transmission when we did the test in the Things Network.

    Thanks.
    Denver


  • Global Moderator

    From my end, I cannot quite pinpoint why it works for EU868 and AS923 and what the potential differences would be. I recommend you to set out the question on the TTS forums, as they have more knowledge about the actual systems. I would do it for you, but I wouldn't be able to provide additional details in the reproduction like you can.

    A lingering question in my mind concerning the nano-gateway setup, is whether the issue is reproducible on another LoRaWAN backend, like chirpstack.



  • @Gijs Hi Gijis, I am certain that there is no issue with the settings of the end devices since I have ensured that the keys are saved correctly in the node and match those generated in the end device section of the TTS.

    I suspect it is an issue with TTS itself not recognising the identities of the packets and therefore not generating any logs on the live data tab of the end device console...

    Or could it be due to the formatting of the payload or rather an issue in the server?

    Thanks.


  • Global Moderator

    Hi,
    I've been good! Thanks for asking. Concerning your previous ADR challenges, I think the new TTS interface also gives many more options to dig trough now :)

    Sorry for the misunderstanding, I indeed read your problem statement incorrectly. To summarize if I understood it correctly now: on AS923, your packet from a node (end-device) to the nano gateway is received on that gateway, and forwarded to TTS, where you can also see it in the gateway console, but the received packets do not show up in the end-device logs? That most likely indicates incorrect credentials (meaning TTS cannot resolve the packet to the correct end-application).

    Though you mention the setup does work on EU868?

    I doubt the issue is with the nano gateway, as I understand, the gateway is able to receive and forward the packets for your application.
    If the issue is not with the credentials, perhaps the location server setting, or region settings in the end-device are incorrect? I know the TTS has many new confusing region settings to play around with.

    Let me know!



  • @Gijs Hi, how have you been doing? Thanks for your help on ADR on the AS923 Frequency Channel earlier this year.

    Probably I was unclear in my previous post.

    I successfully registered the Nano Gateway to the The Things Stack on the AS923 channel and could see live data being received by my gateway on the gateway console. Since my node joined the network via ABP, the data transmitted by my node should be forwarded to the live data terminal under the application/end device console. However, not only that no activities pertaining to the end device had been reported by the console, there was also no live data coming in.

    However, when I tried connecting the nano gateway on the EU868 Frequency Plan, I could see data received on both the gateway console and the application/end device console.

    Thanks.

    Denver


  • Global Moderator

    You should be able to adapt the gateway for the frequency range using the config.py file to reflect the correct frequency and datarate settings (check with the AS923 plan which channel frequency and what datarate settings are allowed). Then, you'll have to setup your node to only transmit packets on that specified channel, as discussed further down the page.


Log in to reply
 

Pycom on Twitter