cannot connect expansion board 3.1 to PC / Windows



  • I am trying to connect the expansion Board to my PC , but all my PCs cannot detect the Expansion Board. I was working on Atom/pymakr and my board was connected with COM6, suddenly COM 6 disappeared and from that moment on i am not able to connect the board to my PC again.
    I open the Device Manager and nothing changes if i connect my Board via USB.
    Did anyone have a similar problem and was able to solve it?



  • @Gijs i am using a lopy 4 tho. Yes it is not detecting the COM port. The device does not show up in the Device Manager. I am assuming that my Expansion Board ist broken. I borrowed the expansion board from a friend and connected it with my lopy4 and everything works fine.



  • @jcaron yes i allready tried it with cmd dfu-util as well
    yes i tried all my ports and i tried on other PCs too.


  • Global Moderator

    And could you elaborate on what you mean with 'the firmware uptader tool was not able to detect the Board.'? Do you get an error message when trying to update the firmware, or does it not detect the COM port? (the COM port should show up even without the Fipy if the green LED is lit)

    If the former, I suspect the issue is with the Fipy. If it does not detect the COM port, could you check the device manager and see if the device shows up there?



  • @apo1997 have you at some point tried to update the firmware of the expansion board (with dfu-util)?

    Did you at any point power the board through other means than USB?

    Have you tried a different USB port on your PC?



  • Only the green LED lights up. Yes the USB cable i am using is a communications cable.

    Afterwards i tried to run the newest software and downloaded the firmware updater tool, but even the firmware uptader tool was not able to detect the Board.


  • Global Moderator

    Please verify the USB cable you're using is a communications cable, and not just a charging cable. Next, you can verify the LEDs on the expansionboard (the green and orange LED should be lit up)

    Also, let me know if you're able to use the firmware updater tool to update the firmware.


Log in to reply
 

Pycom on Twitter