pybytes shows offline despite successful send_signal() messages



  • I'm working with a Fipy and sending batches of signals every 30 seconds. Most of the time, my Fipy just says "offline" although occasionally it will connect and allow me to push code remotely. Sometimes, I am able to stop running code by Telnetting in and using Ctrl-C. Other times, this doesn't work, it appears to break the running code but it restarts when the next alarm cycle returns.

    if I print(pybytes.isconnected()), I get true as a return. but it still shows offline. is there any command that should reestablish the expected ping capability?


  • Global Moderator

    @Stuart-Gall Hi Stuart. There is an issue with how filenames/folders are handled. This will be addressed in the next release, but for the moment please make sure filenames have a dot like main.py or config.json and foldernames do not have a dot, like lib or whatever. Unfortunately things can go wrong with files like README, or folders like .git



  • I think this could be a bug where the size of the files on the device are too large for pybytes.

    try this

    >>> pybytes.enable_terminal()
    >>> Unhandled exception in thread started by <bound_method>
    Traceback (most recent call last):
      File "_msg_handl.py", line 259, in _io_thread_func
      File "_msg_handl.py", line 197, in _receive_packet
      File "_mqtt_core.py", line 398, in _recv_callback
      File "_mqtt_core.py", line 368, in _parse_publish
      File "_mqtt_core.py", line 341, in _notify_message
      File "_mqtt.py", line 91, in set_callback
      File "_pybytes_protocol.py", line 250, in __process_recv_message
      File "_flash_control_OTA.py", line 125, in get_flash_hierarchy
    OSError: 20
    


  • I have the same problem with Lopy4 and Wipy3 devices. Connecting manually to Pybytes is successful and I can see ping messages received by Pybytes in the browser, e.g. 'Last connection 2 seconds ago', but I cannot deploy a new release, upload from Github or list project hierarchy in pymakr online. Pybytes reports device as 'offline' even when pings are clearly being received. I have tried deleting and adding devices to Pybytes again, creating new projects, erasing device memory and re-flashing firmware (1.20.2.R4). I have also tried with brand-new Lopy4.

    connecting to Pybytes...
    WMAC: 3C71...
    Firmware: 1.20.2.r4
    Pybytes: 1.6.1
    Initialized watchdog for WiFi and LTE connection with timeout 1260000 ms
    WARNING! Using external WiFi antenna.
    WiFi connection established
    Connected to MQTT mqtt.pybytes.pycom.io



  • Hi, i have the same issue. I couldnt find a solution so far.


Log in to reply
 

Pycom on Twitter