Modem attachment refusal

  • We're running what we think are the latest gpy/modem firmwares

    >>> import sqnsupgrade;
    <<< Welcome to the SQN3330 firmware updater [1.2.6] >>>
    >>> GPy with firmware version 1.20.2.r4
    Your modem is in application mode. Here is the current version:

    This printout is always followed by a core dump which doesn't inspire much confidence in the latest firmwares but that's another matter.

    The modem won't attach

    >>> from network import LTE
    >>> lte=LTE()
    >>> lte.attach()
    >>> lte.isattached()
 says this is because the cereg might be wrong (latest formware needs cereg=1), so we checked

    >>> lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 1,0\r\n\r\nOK\r\n'

    This modem was working fine till we tried lte.attach(band=28), which is the catM1 band in AU, to try to speed up first time attachments (suggested at It hasn't attached since!

    We tried to backup out of the hole of yet another failed modem

    >>> lte.factory_reset(debug=1)
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    TypeError: function doesn't take keyword arguments
    >>> lte.factory_reset()
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    OSError: the requested operation failed

    We tried reloading the 48829 firmware into the modem, still won't attach. Any one think of something else we might try to get attachment working again?

  • Finding all these (old?) gems trying to solve my own issues.

    Did you fix this? If so, what worked.

    Anyone in a similar situation, I would suggest going back to an old firmware (for me 1.20.1 recovered my device), then see how far up the firmware chain you can get.
    Having said that, I still don't know if my code will run now, but all the preliminary REPL tests are promising...

Log in to reply

Pycom on Twitter