Firmware Tool "Could not connect to the update server!"

  • I finally managed to get one on my devices working on one of the newer releases 1.20.2.r4 after being stuck at 1.20.1
    I realised you had to clear the flash etc in the upgrade page otherwise you get a flashing red light and no command prompt in pymakr / vscode

    today I tried to update another one but i get the message
    "Could not connect to the update server!"

    whats causing this ? isthe server down , the DNS entry it queries seems to be valid
    Re-downloaded 1.16.5 just incase but still the same

    Tried the direct download page, but cant seem to see that image listed

    Also what is with the naming scheme
    .b beta ?
    .r release ?
    .rc release candidate
    what are development releases ?

    the standard ESP32 offers daily release I can see what they are doing with pycom it seems to be very difficult, no change log, and i find myself going around in circles

    What firmware should you use, don't want to be bleeding edge, but want something that works

Log in to reply

Pycom on Twitter