Pysense Board is not connecting

  • Hi guys, I'm starting an IoT project and I have the following problem:
    I'm using Visual Studio Code with the Pymakr extension, and when I connect my Pysense Board via USB it get stuck with the following message "Connecting to /dev/ttyACM0..." but never connects.
    I've tried giving permissions with "sudo usermod -a -G dialout $USER" but nothing has changed.
    I've also tried using Atom and connecting the board via screen and nothing happens either.
    By the way: I'm on Linux Mint 20.1 in a Lenovo IdeaPad Gaming 3.

    If someone can help me I will be very grateful.


  • Global Moderator

    Alejo, Tiffany and Serenabilly: The blue light blinking indicates the micropython is running correctly on your board, so you definitely have it powered and the firmware is not corrupted.

    It most likely means you have a serial port issue. On Linux (Alejo) it would be worth trying with a different serial port program (putty, screen, minicom) and see if it gives an error message.
    On other platforms we would need some more details: what platform you are on, what you have tried, and what software versions you are using.

  • Same issue over here, wipy3 NOT detected via WiFi nor USB, the light is blinking blue. After OTA updating. I left from Pycom no response in all topic. No way to recovery a CORRUPTED FIRMWARE!!

  • @jcaron Same issue over here- Pysense with Sipy is NOT detected via WiFi nor USB- the light is blinking blue…

  • @Alejo-Severini-Montanari what development module do you have installed on the Pysense? It is in the right orientation? Is the LED on the module flashing blue?

Log in to reply

Pycom on Twitter