firmware corrupted

  • HI. I have wipy 3. After a firmare update by the pycom tool my device no longer connect via usb. It no longer go to safe boot. The device is new. I lost my money? How can i solve plz?

  • @serenabilly I mentioned to try Putty to sort our the reason for the problem. If there is a driver issue, that can be better analyzed without the overhead of an IDE, which adds it's own layer of complexity and errors. One the communication works with Putty or the like, you can go for debugging an dreconfiguring pymakr. The latter has to be done about every time, when a new version of VC or Atom is published.
    For tansfering files between a Pycom board and my PC I prefer ftp with FileZilla as client. PC file managers work as well, but FileZilla is more robust. There are also a command line tools like rshell or mpremote from the project, or Thonny as IDE as an alternative to pymakr.

  • @robert-hh ok ty but i don't know how tu put all my code by putty. I'll retry all with linux. Ty all.

  • @serenabilly About Linux: You have to be in the dialout group to access the ttyACMx port of the board. Using sudo works as well. Some Linux installations have a modem manager, which tries to set up a modem on a serial device. So you must uninstall them modem manager.
    About Windows: Search the forum for Zadiq, which seems the tool to set up the device driver.

  • @serenabilly When you say "Don't Working". Do you get an error Message? With Linux, you can use Picocom as Terminal emulator.

  • @serenabilly I'm using Debian Linux. I used Mint Linux on some computers as well. But Ubuntu should work too. Do you use it plain or in the WSL environment or Virtual Machine? Can you select between a USB2 or USB3 port?

  • @robert-hh which linux distro do you use please? Ubuntu with snap don't worknig. I'm going crazy to connect the board. Thanks all

  • @serenabilly Can you connect with simple terminal tools like Putty or TeraTerm? IDE's like Atom and PyMakr add their own level of complexity. Using simple tools you can Debug step-by-step. With Pycom expansion boards there used to be a problem with USB drivers at Windows.
    I cannot tell a lot about this Windows USB driver problem since I use Linux for these MicroPython boards.

  • @robert-hh the issues is the driver, i can't do nothing if first i can't connect via USB. I tried in windows 10 and windows 11. Pymaker in Atom have a critical error of deprecation both in win 10 and in win 11 . Nodejs installed. pytrack.inf driver is reject. I think you need update you all repository and software.

  • Ok thanks. I think the issues is the windows 11! I worked alway with win 10 but now i've a loto of issues with other boards . don't start in my machine. Node.js ok, python ok etc. I use a application .exe NodeMCU-PyFlasher but nothing USB connection. I think win11 don't work for some develope board. Iill try to install a linux in dual boot .

  • @serenabilly It the heartbeat LED is flashing, like you told in another post, then the WiPy is alive and working. So it may be related to the way you try to connect.

    Besides that, you can always get back to start by doing a full erase of the chip using the Pycom updater or The ROM bootloader of espressif will always be present. After the full erase, you can reload the firmware.

Log in to reply

Pycom on Twitter