PSM LTE-M Not Registering Properly



  • I'm having trouble with PSM on LTE-M connecting thru Verizon. My specs are the following:

    GPy v1.2
    GPy with firmware version 1.20.2.r6
    LR5.2.1.0-48829

    It appears that possibly Verizon is rejecting my PSM request in a strange way or I have some other issue.
    (I am aware Verizon does have a requirement that TAU >= 186 minutes).

    First, I init LTE with

    lte = LTE(carrier='verizon', psm_period_value=30, psm_period_unit=LTE.PSM_PERIOD_10H, psm_active_value=1, psm_active_unit=LTE.PSM_ACTIVE_1M)
    

    (I've also tried doing this step with AT CPSMS commands and achieve identical results)
    I attach to the network successfully with:

    lte.attach(band=LTE_band, apn="secret", cid=3, type=LTE.IP)
    

    and then I run the following:

    print(self.lte.send_at_cmd('AT+CPSMS?'))
    print(self.lte.send_at_cmd('AT+CEREG?'))
    print(self.lte.send_at_cmd('AT+CEREG=4'))
    print(self.lte.send_at_cmd('AT+CEREG?'))
    print(self.lte.send_at_cmd('AT+CEREG=1'))
    

    and get the following results:

    +CPSMS: 1,,,"01011110","00100001"
    
    OK
    
    
    +CEREG: 1,1
    
    OK
    
    
    OK
    
    
    +CEREG: 4,1,"7803","01D4FB02",7,,,"","00000101"
    
    OK
    

    You can see on the last CEREG?, <"","00000101"> have been registered as my PSM values from the network. I don't know what this means or what I could be doing wrong. The 00000101 isn't anywhere in my code and I get a blank for another value. No matter what I set the values to or how I set them, I get that exact same result. It makes me think it's the network but maybe I'm just doing something wrong? If I turn off PSM, that does show correctly at least.

    I've tested on several GPy firmware releases, different LTE firmware, and different GPy hardware and the same thing occurs.

    When I do

    lte.deinit(detach=False, reset=False)
    

    and then machine.deepsleep; I get paging at 1.28s intervals (default paging) and I remain running at ~300uA @3.6V. I do remain attached as hope for on wake but it's just too high of a power draw (especially with the constant paging). I've gone ahead and switched to eDRX to at least get rid of the paging for the most part but I'd really like to be able to deep sleep down in the double digit uA range w/ no paging.

    Any help is appreciated. @peterp



  • @pycom I'm assuming support for GPy is just dead at this point? I've waited over a month for some sort of support, micropython firmware is falling further and further behind, and we haven't had a new firmware release in almost a year?



  • Is my question in the wrong place? Has Pycom discontinued forum support entirely? I'm testing about 25 GPy's right now for a much larger scale deployment; any help would be greatly appreciated.



  • @Yusuf-BAYLAV Can you help get this question asked to the right person?



Pycom on Twitter