PyGo



  • I have just received my 2 PyGo's and a charger, good, but the batteries will not charge, bad.
    Putting them on the charger they just get very hot and sometimes show the battery outline.
    Pylife can sometimes see them when on the charger but mostly not.
    When Pylife can see them and I add them, they show as 'disconnected'.
    What is going on?



  • @Pete-Allen-0
    Hello Pete,

    I really did my best -- with tons of tests to recover : same status as explained above.

    Status as of today :

    • There is no more indications on the screen (previously was Hello and Bar Gauge)

    • There is no automatic BT recognition from my Android Phone (was the case before, at least once)

    • This is difficult to get Pygo identified from my Android Phone scan (but probably that after several attempts it may work again)

    • When Pygo was identified, the Firmware Upgrade was initiated, up to the Wifi local link (successful -- I had a "Connected" popup). However, after 10 sec. it was systematically reporting a failure error for the FUpgrade

    As I wrote above, I received a QI Wireless charger, not the craddle, so I cannot try the manual procedure

    I will make a last attempt tomorrow (after one day without charge). Reloading the Android Apps, etc...

    Last point, I do not have any SIM slot at the location indicated by the documentation (just below the screen) -- weird for me.

    Hope that helps and you can find what is wrong or a recommendation

    Regards


  • Pycom Ambassadors

    Is there an update to the iOS app coming? Perhaps a testflight link? I have no android devices in my possession.

    I can pair over BLE but my pygo never gets to the point of activating its wifi AP.



  • @Pete-Allen-0 said in PyGo:

    roid please update the app on the play store and have another go. Hopefully that will solve these issues.

    Hi all,

    I did it, with a lot of hope this will fix my issue : same result -- 10 seconds after the start of the firmware update, there is an error message (try again etc...). this is systematic. After several attempts, I even do not see the screen ON (previously I had the Hello + the bar moving). The doc. is talking about a possible manual firmware update -- but I received a QI wireless charger, not the cradle -- So I am stuck with the device.

    Last minute note : I tried with an iOS phone -- even worse : the Pygo is not recognized at step1 (several attempts as well)
    Last second note : I let him sleep one night to be sure the charge was back to zero -- same - same - same.

    Is there a chance to save it from the paradise of the non working electronic gadgets ?



  • I've had both PyGo1 discharging for past couple of days, I tried to charge 1 last night but nothing happened. It shows nothing on the screen so can't even perform a firmware update.
    Are these now dead and need replacing or is there some other way to get them to activate?

    Andrew


  • Global Moderator

    Hi Both,

    A new version of the Android which fixes some firmware updating issues has gone live last night, so if you have been unable to update via Android please update the app on the play store and have another go. Hopefully that will solve these issues.

    The temperature issue is fixed in the firmware update, so it's important to focus on that. There is a thermal fuse, but we have reduced the wireless charging current in the new firmware to cool things down.

    As a generaly note I would recommend not fully charging your PyGo until you have managed to do the firmware update - if the GPS bug hits it is quicker to sort with a nearly empty battery.

    If you are still having issues please let me know and we will try to get you up and running.


  • Pycom Ambassadors

    Experiencing the same. Also users on twitter with the same too: https://twitter.com/johnhegs/status/1539198307519631360


Log in to reply
 

Pycom on Twitter