Getting started with PyGos and Pylife


  • Global Moderator

    Welcome to the PyLife section of the forum. This is a space for discussion and help about using PyGos with the Pylife app.
    The first place to go to get started with PyGos is our documentation:
    https://docs.pycom.io/pylife/

    This should cover everything to get you up and running, and please say if there are things that aren't clear.

    For those of you who like to plug things in and try them out before reading and documentation: it is important to do a firmware upgrade as soon as you turn the PyGo on.

    If you are on Android, please make sure you are using the most recent version of the app.



  • The only function that works reliably is: "Forget the PyGo" 🤣 LMAO you really made my day!



  • @thinginnovations Every few days I have another short look at the PyGo & PyGo App. Yesterday I noticed that there is a new version of the App. SO I loaded it.
    The only change I could notice was the change in the version number. No additional feature, not better interaction with the PyGo. The PyGo are still discovered, when being fully charged and close to the phone, unless they were set to "eco" mode. No setting of LoRa mode, no display of the charge state.
    The only function that works reliably is: "Forget the PyGo"



  • @Alberto-Fassio That's not good. So something is broken:

    • the PyGo
    • the cradle
    • the cable to the cradle.

    Do you see a com device for it when the the cradle is connected to the computer? The com device is created by the cradle itself.



  • @robert-hh I have charged the Pygo all the night. It does not work!!!



  • @thinginnovations Fuck it, why are you doing Pycom's job fixing this mess?



  • Also, while viewing the output I see the same error repeated :

    >>> Traceback (most recent call last):
      File "_ble_rpc.py", line 236, in feed
      File "_ble_rpc.py", line 236, in <listcomp>
      File "_ble_rpc.py", line 245, in resolve
    TypeError: 'int' object isn't iterable
    

    Guessing there are some incompatibilities between the app and the firmware.

    Cheers

    Andrew



  • @robert-hh Good call, thanks.

    I do get this now when trying to set LoRa frequency:

    >>> Client connected
    {}
    Traceback (most recent call last):
      File "_ble_rpc.py", line 236, in feed
      File "_ble_rpc.py", line 236, in <listcomp>
      File "_ble_rpc.py", line 253, in resolve
    AttributeError: 'RPCHandler' object has no attribute 'set_lora_freq'
    

    Going to try a few more things.

    Cheers

    Andrew



  • @thinginnovations If you have a USB terminal window open while trying someting in the APP, you'll see error messages about faults in RPC.
    I never got the app to show the battery level.
    So no, the devices are not useful for anything at the actual state. But maybe Pycom is working at bringing some functionality to the device. Maybe not.



  • I'm getting the same battery charging bars after charging the devices in my makeshift holder. They both show 100% via the app, I try to set the LoRa band but this cannot be set for some reason, even though the PyGo are showing as connected.

    I try to wake the Pygo with a double tap but they either show nothing or just the battery charging indicator. I can get the REPL to show when USB uart adaptor is connected.
    I was able to issue reset() and see the device restart and that's about it. No change to display. Is the current firmware still not working?

    Regards

    Andrew



  • My screen never says hello. It seems to be charging with the bars going up and blue light on the charger



  • @Alberto-Fassio When placed into the cradle, it may take an hour or more until it starts charging the fist time. The devices seem to arrive with a completely empty battery.
    You could check in the cradle & device, if the contacts are clean and correctly aligned.



  • I received my Pygo two days ago. It does not charge nor configure. Impossible to load new firmware even from cradle. Unusable



  • Did you get any updates on this? Still waiting for a cradle here too.
    @hjoe


  • Pybytes Beta

    @Pete-Allen-0 said in Getting started with PyGos and Pylife:

    make sure you are using the most recent version of the app.

    Which version number will this be? And where is the version number shown in the App?
    Pete it's tim to tell all of us the truth



  • In the past few days they have finally included a link to the newest android app. Downloaded it, but it is just a waste of bandwidth. First it did not want to update the previous version. Ok, uninstalled the older one, then i installed the new one. Since my first day with the least connected devices i forgot my account password, so wanted to change that. I got a link via email just as one would normally expect, the link opens up a webpage you are supposed to enter a new password twice, but for some reason as you are typing, your input gets populated in both input fields... What is more of a problem, nothing happens when you click on the save button. No wonder the app does not accept the new password if the webpage does not replace that.

    Never seen anything like that in case of a released product. One would expect such to happen when an amateur who knows some PHP and HTML and has never done something like that is trying to come up with a solution for the very first time.

    I short version check reveals they linked Pylife app version 1.0.9 into the docs... well... i had previously 1.0.10 installed.

    Guys who is sitting behind the wheel? Do you care at all what the hell you are doing?



  • @Pete-Allen-0 So I received my PyGo devices yesterday, uploaded the new firmware using the supplied cradle, and that's it for the moment. The devices do not charge beyond a display of 25%, the Android PyLife app does simply lock up, and besides that the pygo devices behave like a severely handicapped WiPy3.
    I can connect though USB to REPL, I can connect to my local AP, I can exchange files using ftp, runs scripts, ...
    I could start playing around with the built-in modules like _Display etc,, to find the interface to the display and the radios. But why? What was the intended use of these devices?

    Edit:

    • The PyGo2 shows full charge, the Pygo1 25% max., and drain empty pretty fast.
    • The PyLife app needs access to the position to work. Otherwise it simply stalls without any complaint.
    • Trying to set the Lora Region fails.


  • What I'm wondering is there anyone whose these PyCom devices do what they are supposed to do? I have made a 3d printed cradle myself. With that I can charge them, but that's about it, they don't keep functioning. Also the new IOS update has not brought any improvement. I find it really shocking that PyCom is sending to its KickStarters after more than two years. Frankly, I'm assuming this is not going to work out.... wasted money.



  • So it seems that the PyGo device I ordered are on their way now. But is seems to me quite thoughtless that the devices are shipped to the EU from the UK instead of the Netherlands. Pycom should be sufficiently professional to consider tax issues of their customers. Companies like Mouser of Digikey can handle Worldwide shipping without addition tax and customs trouble for their customers. So it is possible. With the actual approach of Pycom, selling to the EU is aggravated.



  • @Matthijs-Mullender My Pygo2 does not charge too.


Log in to reply
 

Pycom on Twitter