Atom stuck at "Connecting to COM..." Lopy4, expansionboard firmware updated in application mode?

  • Hi! I'm new to microelectronics and have run into a very annoying issue. I'm working with an expansion board 3.1 and FiPy where everything is working great, but when I try to connect LoPy4 on an expansion board 3.0 with USB, atom either gets stuck at "Connecting to COM7..." or sometimes gives the error "Failed to connect (Error: Port is not open)". The REPL never reaches ">>>", so I can't communicate with the device. Running Windows 10.

    I've reinstalled atom, restarted and reset all modules and devices several times, used different cables (they all work for my other setup) and updated the firmware for the board and LoPy. I was following the instructions given at (for the expansionboard) and got the right output after running the dfu-file (ending with "No error condition is present
    Done!"), so I would guess that everything worked out fine but as the device shows up in the device manager and atom recognizes the port but closed, I'm wondering if the installation happened while the device was in application mode (as it exits update mode after 7 sec, and the installation wasn't done before that happened). I've inserted the instructions for how to handle this issue (from here:


    I don't really understand what it means though (the text makes it sound like the Serial USB (CDC) is correct while the image makes me believe that usbser is correct). Zadig shows the usbser driver for application mode and libusbk for update mode, so I guess that's correct? Also, don't know if it's relevant, but after the update, the device is called "Expansion3" instead of "USB Serial Device" in both Zadig and device manager.

    Has anyone have a similar issue and solved it? Can it be something else? Thanks in advance!

  • @Agnes could be silly thing.. but since the device is recognized on COM3 why u r trying to connect on COM7 via Atom?

Log in to reply

Pycom on Twitter