FiPy on Expansionboard 2.1A stopped functioning

  • Serial connection not working

    I have just started using my FiPy on an older expandion board (only one available to purchase in Australia). It worked fine when I first powered it up. But on second use; I no longer get any Comm port enumerate in device manager when I connect the board.

    Tried all combinations of power supply options (just powering with USB, also powering with lithium battery, external regulated 5V to the Vin) - multiple laptops, multiple serial cables - no dice.

    The device does appear to power up and start blinking its blue light - which suggests to me it running its default code.

    Any advice / known issues I should be aware of with this hardware? Recommended tests? This device is not too easy to debug given the lack of schematics - am I missing a repo or something?

    Thanks in advance

  • Well - this is embarrassing..

    I first tested this at home, I had 3 micro USB cables - the first one I used worked. I travelled to site; bringing 2 micro USB cables with me - and I'm sure you already know where this is going..

    Those cable appear to power up the FiPy only - and not allow the comm's to function. I borrowed a 3rd cable yesterday - and it worked immediately..

    Thanks for your support - cutting all my "power only" micro-USB's in half..

  • @Antman Are all jumpers closed?

  • @Antman The expansion board should show up as a USB device even without the FiPy installed.

    • Did you change any of the switches?
    • Have you tried to upgrade the expansion board firmware (though I'm wondering if that applies to the 2.1 version or only 3+, don't remember when they switched to a PIC for the serial/USB connection)
    • What OS are you using on your computer?

    Also you mention serial cables, you mean USB cables, right?

Log in to reply

Pycom on Twitter