Difficulties finding microSD card (Expansion Board v3)

  • Hi guys,

    I am working on implementing OTA updates through the microSD holder on the Expansion Board v3 (v3.1 to be precise).
    I have two sets of LoPy4 + E.B. here for testing. One is bare with only an SSD1306 connected and always succeeds in finding the SD card, while the other has all other connections as well and has trouble finding the SD card.

    The SD card is initialized using these two lines and results in the error:

    >>> from machine import SD
    >>> sd = SD()
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    OSError: the requested operation failed

    As far as I can tell, the SD card uses pins 3, 4, 8, 9 and 10 from the pinout diagram. Pins 9 and 10 are able to use I2C meanwhile without any problems as I found out from testing my bare version. Pins 4 and 8 are always disconnected on both devices, and I am hoping to use Pin 3 although it is currently disconnected on both devices as well.

    Interestingly, from the REPL I am sometimes able to initialize the SD card on the full device as well! But after a reboot, it fails again. I have no clue why.

    Does anyone have a suggestion what I could be doing wrong or what could be tried to solve this problem?

  • @robert-hh thanks! I had read that somewhere momentarily and disconnected pin 23, but it was still pulled from software as a deepsleep wakeup pin. So removing the jumper was not enough. Moved the pin and it works now, thanks!

  • @Steven-Boonstoppel The Pycom SDCard driver uses Pin 4, 8, and 23.

Log in to reply

Pycom on Twitter