Firmware update, Connected to Lopy but update fails



  • Hi there,

    I am trying to upgrade the firmware of my Lopy with the Pycom Updater under Windows 10. I have connected the Lopy to my FTDI adapter. The communication with the board seems to work according to the log:

    Connecting....
    Uploading Stub...
    Running stub...
    Stub running...
    Changing Baud rate to 115200
    Changed.

    Failure!

    If I change something (switch RX with TX or leave GND<->G23 bridge) it does not work at all. It is 5v powered but jumper on FTDI is set to 3.3v for Rx and Tx. There are no other wires conencted to the board besides antenna, 5v, Gnd, Rx, Tx and the bridge GND-G23.
    So I guess wiring is ok. A simple "Failure!" is not the most helpful error emssage that I have seen in my life. I would appreciate any information that helps me to solve the issue.

    Thanks a lot.

    P.S. Although not required anymore I have successfullly run the Flash_debug without any effect:

    PS C:\Program Files (x86)\Pycom\Pycom Firmware Update\Upgrader\workaround> ....\Python27\python.exe .\flash_debug.py COM13 write 0x0 2
    Connecting...
    value: 0x0
    length: 2
    write 0x60002008 0x00000000 0x00400000
    write 0x60002010 0x00000000 0x00000000
    write 0x60002000 0x08000000 0xffffffff
    write 0x60002008 0x00000000 0x00400000
    write 0x60002010 0x00000000 0x00000000
    write 0x60002000 0x08000000 0xffffffff
    write 0x60002008 0x00000000 0x00400000
    write 0x60002010 0x00000000 0x00000000
    write 0x60002000 0x08000000 0xffffffff
    write 0x60002008 0x00400000 0x00400000
    write 0x60002010 0x00000000 0x0000ffff
    write 0x60002000 0x04000000 0xffffffff
    write 0x60002008 0x00000000 0x00400000
    write 0x60002010 0x00000000 0x00000000
    write 0x60002000 0x08000000 0xffffffff
    get status: 0x0
    ESP DEV DISCONNECT...



  • @livius said in Firmware update, Connected to Lopy but update fails:

    @Camot
    look here
    https://forum.pycom.io/topic/763/firmware-upgrade-troubleshooting-checklist-procedure/19

    i will recommend you to press reset button just before upgrade
    and unselect "fast connection" in firmwere upgrade software

    I have already tried it. Pressing Reset does not change anything. The result and log is the same. The speed 115200 as shown above is with "Fast Connection" unchecked. With "Fast Connection" it uses 921600 :/



  • @Camot
    look here
    https://forum.pycom.io/topic/763/firmware-upgrade-troubleshooting-checklist-procedure/19

    i will recommend you to press reset button just before upgrade
    and unselect "fast connection" in firmwere upgrade software


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.