failed to set dtr/rts

  • I got someone else with a Windows PC to try it, and it seemed to be working for him. I laughed when he used Labview to decide whether or not it was working :)

    After I googled around a bit, I stumbled across hints that rebooting the host might resolve it, so I did and it is now connecting again via the USB UART on the pytrack board. I've just been able to sync the 3 libs across and still have the REPL up. Will post back if there are other developments.

  • New user here, and I've just experienced the same thing.

    I got my first lopy yesterday along with an Expansion Board 2.0 and had no issues getting them up and running (including yesterdays fresh FW update). Had the lopy connecting to my WLAN and the FTP/telnet server accessible. Also had no probs with the USB UART connectivity via the ExpBrd2 with the dev tools in the Atom editor and with GNU-screen.

    Today my first pytrack board arrived. I DFU updated it with the latests FW and then I fetched the libs from github and was about to sync the 3 libs onto the device, when the Sync in Atom failed. The device no longer responded on the serial port. I looked at the dmesg output, and it is the issue described above.

    I've un/replugged the device a few times. The handshaking error occurs in dmesg output whenever a prog tries to access /dev/ttyACMx. I also have an Arduino, which seems to use the same USB UART driver and that's working fine still (note that for the avoidance of doubt, it was not plugged in when the issue arose, I only plugged it on to verify that it still worked).

    I'm running Ubuntu 16.04 LTS x86_64 on kernel 4.10.0-30.

    I can still access the device over telnet and ftp. I assume that I would regain serial connectivity with the lopy if if reverted to the ExpBrd2, but I really want to play with the lopy and pytrack.

    I notice there has been no updates on this topic for a while. Is this a known problem, or have workarounds been discovered?

  • @jmarcelino Thanks for your input. I've tried this, but this command leads to the same error message: cdc_acm 3-1.2:1.0: failed to set dtr/rts. And connections from Atom don't work neither.

  • @tobru
    Can you try
    stty -crtscts < /dev/ACM3

    from the Linux shell to disable hardware flow control?

  • Just tried the master branch of the Pymakr plugin, but no change in behaviour.

Log in to reply

Pycom on Twitter