USB com issue after updating to new firmware 1.7.5.b2



  • I have several LoPys and have tried to connect on two Win10 systems, both no longer 'see' the LoPy(s) when pluged in (using the LoPy shield). The Atom plugin can no longer detect the com port, the firmware updater no longer sees any LoPy com port. The LoPys do not show in the windows 10 device manager in the Universal Serial Bus controllers section, nor do the LoPy(s) show up in the devices and printers section of the control panel.

    I have tried 3 usb cables with the same result.

    I first thought it was an issue with my Win10, plugging in one of the LoPys crashed Atom and fragged the Atom config file to read NULL (a bunch of times). Win 10 then blue screened with a file dump that was useless. After restarting the LoPys do not register when they are plugged in with the shield.

    I reinstalled the FTDI drivers from the link in the pycom.io documentation with no change.

    They were working, I only updated the firmware. On the next restart of my Win10 I could no longer see the LoPys.

    I have attempted to update the USB drivers, checked the system for corrupt files with sfc /scannow

    I am at a loss and need help. I need to get working on these. I was just working on trying to get a BME280 connected and working, but I can't even see the LoPys.

    Also, the pycom.io web site seem really, really slow right now.



  • Ok..it works again using /dev/cu.usbmodemP* device. That confused me...usually its always a tty. Thanks a lot!!



  • @jmarcelino Thanks. Firmware update did work. But how do I program a LoPy connected to the board? I remember that this has been working recently.



  • @harix
    The Pysense isn't an FTDI board, it's standard USB Communication device class (CDC) device.

    Even if something is wrong if you can see it on USB you may be able to update the firmware on it and get it working again: https://docs.pycom.io/chapter/pytrackpysense/installation/firmware.html



  • I am having the same issue right now. Pysense FTDI stopped working for some reason. I have tried Linux/Max/Windows. The device is just recognized as a general purpose USB device. I'v already contacted sales for a new board.



  • @jmarcelino
    I agree, its strange (and frustrating). I have windows 10 Pro build 1703.
    I have tried 3 different usb cables. The usb cable I was working with at the office is different than the cables I have at home.

    I ran out and got 3 more, one of the new ones worked. My understanding was that the usb cables I have are not charging cables, they work to sync my android phone, etc...

    The 5th cable I tried worked. So there is no USB or Driver issue. It's a cable issue. I must have crappy cables or my LoPy's and boards are a little more sensitive to quality cables.

    Good to know.

    Thank you for your help.



  • @ledbelly2142
    Which Windows version are you using?

    It's really strange that FTDI would stop working. It's the most compatible USB/serial adapter in existance.

    Are you sure you're not using charging-only microUSB cables?



  • @jmarcelino
    Thank you for responding. Yes, I am using the expansion board that ships with the LoPy.

    I have tried other USB devices on the 2 separate windows 10 computers, 'other' usb devices work, so I don't think it's the usb bus/driver.

    FTDI is not listed in Com ports with LoPy with expansion board connected. There are no COM ports listed, the FTDI driver is not triggering the windows process that acknowledges them. The USB is not 'seeing' them to bind them to a com/serial port.

    Yes, the FTDI driver I have reinstalled is from the link you provided, same link that is in the Pycom documentation.

    The expansion boards I have all worked before the firmware update. I have 15 of them, none of them work.

    This is the same issue on two separate Windows 10 systems, two separate laptops. My gut feeling is that it's a windows issue. Perhaps a recent windows update conflicts with the FTDI driver. The two systems I have both are updated with the latest massive Microsoft update (plugs the holes publicized by NSA hack).

    I have tried two separate systems and many different expansion boards with the same result. I think this is a windows compatibility issue.

    Thank you for your good suggestions, any additional suggestions are appreciated.



  • @ledbelly2142
    If by "LoPy shield" you mean the Expansion board (the PySense and PyTrack are different) that has little to do with the LoPy, you can even plug in the expansion board without the LoPy and you should still see a serial port appear on Windows (I use the expansion board as simple USB-TTL adapter sometimes)

    The Expansion Board won't appear as a "Universal Serial Bus controller" but under "Ports (COM & LPT)" in Device Manager as a 'USB Serial port xx'
    If you click through you should see Manufacturer: FTDI listed for it.

    If it's not appearing I'd really re-check the drivers. I don't know which link you used (is there one from Pycom.io) but the best it go directly to the source: http://www.ftdichip.com/Drivers/VCP.htm

    The Expansion board could also be broken for some reason (I guess you can try another one if you have it, or try connecting the LoPy using a cheap USB-TTL 3.3v adapter and a breadboard)

    Is USB in general working on the machine? Can you try another device?



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.