Pymakr with Atom 1.19.2



  • Hey

    Is anyone else having issues with the latest Atom version 1.19.2 and the Pymakr plugin? It fails to load on start up since Atom updated yesterday.

    The error message is saying it Could not locate the bindings file "serialport.node" Error Message

    I've tried to find the older Atom installers but they only go back to 1.19.0 which doesn't solve the issue.

    The missing file is present in a directory that wasn't attempted but moving it causes an error saying that is was compiled with the wrong version of Node.js!

    Cheers

    Dave



  • For who wants to try, there is a fix for this issue on the develop branch now. See my last comment in https://github.com/pycom/pymakr-atom/issues/1#issuecomment-324798001



  • got same problem on atom 1.19.3



  • Hey

    Downgrading to 1.18.0 (thanks for the link) has worked for me - I think deleting the .atom folder helped a lot as previously I was only deleting the Pymaker package folder.

    Thanks for the tip on Filezilla/Putty, I have used that approach before and was just about to go back to it!

    I also tried to get VSCode working, it looks pretty similar to Atom but I had issues getting the Pymakr plugin commands to work - just kept saying they were missing. Would be nice to get a more complete IDE for development as I have a few ongoing projects with the boards and find it a bit tedious switching between them and sharing the common code base.

    Thanks for everyone's help.

    Cheers

    Dave



  • I'm getting the version mismatch error on WIN10 and reinstallation, downgrade doesn't solve the issue. Interesting, it was working fine till I downloaded the pysense/pytrack fw update tools, except sync which never worked. No idea how they are related. After wasting some time I dropped ATOM and using a putty to access device and FileZilla to move programs and files to LoPy. It is not so cool as ATOM would be but it works stable.

    TBH I never really liked ATOM.



  • Had the same error, but managed somehow to downgrade (i think by deinstalling everything, deleting .atom and using the initial downloaded installer again), and then under help -> about atom -> unchek the auto download updates feature.

    Here you can download working 1.18.0 packages: https://github.com/atom/atom/releases/tag/v1.18.0



  • Further update;

    Trying the manual install of Pymakr 1.0.2 using "apm install Pymakr@1.0.2" as described as the fix to the following does not work too.

    https://github.com/pycom/pymakr-atom/issues/24

    https://github.com/pycom/pymakr-atom/issues/25

    I also check that apm is using Python 2.7.12 and not 3.x using "apm --version"



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.