Wify AP mode not Working After firmware update



  • Just did update my wipy 2.0 using the update script.
    After it finished i pulled the wire (now the LED lid up bright) and reset.
    It started and i verified firmware is 1.8 in serial terminal.
    default Wify was visible and i could connect .
    Unfortunetely neither Telnet nor FTP ist working and no device is shown in network discovery.
    I tried to setup a different ap manually w/o success.
    Now i setup connection to home wify and this worked, i could Telnet...

    All Cables removed, Power on - default AP Not working.
    Also no wify Information in serial during startup ( thought it was printed with 0.9 firmware).
    I checked wlan.ifconfig(id=0)
    Reports 4*0.0.0.0 !
    And for id=1 the expected 192.168.4.1 ...strange.

    Is this a firmware issue or did i just killed the wify Transmitter somehow?

    Any other debugging possible?

    (Quick Checking Bluetooth Scan didnt find any devices either, will try again tomorrow.)



  • @bastler said in Wify AP mode not Working After firmware update:

    BTW, the pyupgrade script (toolversion=67634306)
    I got from debian apt-get
    Has a bug in lines 177..183:

    How did you get pyupgrade woth apt-get? You should load it from here: https://pycom.io/downloads/
    During update it should be clear which type of device will be loaded.
    Loading the wrong formware is not expected to work. In the serial terminal REPL prompt, you should be able to tell. Just enter:
    import uos
    uos.uname()
    or push Ctrl-B
    Edit: if anything else fails, try to start over by erasing the flash, using esptool.py
    Edit 2: Indeed, lines 177..183 look strange, but they are only used for manual device selection. This looks like a candidate for a bug report here: https://github.com/pycom/pycom-micropython-sigfox



  • @robert-hh
    Thanks for help.
    Can the antenna switched for already configured wify?

    I tried this:
    wlan=WLAN(WLAN.AP)
    wlan.init(mode=WLAN.AP, ssid='sensor1', auth=(WLAN.WPA2, 'password'),channel=6,antenna=WLAN.INT_ANT)
    wlan.ifconfig(id=0,config=('192.168.4.1','255.255.255.0','192.168.4.1','8.8.8.8'))

    Not working, also with ext antenna and other channels and id=1 set up.

    os.uname()
    Shows 1.8.0.b1 version=1.8.6-760-g90b72952.
    Is there a newer version?

    But wait - isn't there something different with wify in Germany/europe with the channels which requires different firmware?

    Maybe I got US configuration?

    BTW, the pyupgrade script (toolversion=67634306)
    I got from debian apt-get
    Has a bug in lines 177..183:
    Case $device uses recent_lopy if device is wipy and recent_wipy if device is lopy !!!

    Though that didn't change behavoir after reflashing today, unless this was a fault only to be made once...



  • @bastler Maybe by bad luck it's switched to external antenna. Try to enable the internal antenna, even is it is the default.


 

Pycom on Twitter