pymakr: Upload failed.

  • I consistently get an error when trying to upload files using pymakr 1.20 on atom.

      Reading file status
      Failed to read project status, uploading all files
      Creating dir lib
      Creating dir lib/ina219
      [1/10] Writing file boot -
      Upload failed. Please reboot your device manually.

    I'm connected through usb, and repl works fine. Also the run command (which needs to upload code also?).

    Any suggestions for diagnosing or fixing this? The error message is a bit terse.

  • Pybytes Beta

    Hi, can you share the ina219 library that you are using?, Thanks in advance

  • Latest release of Pymakr (1.2.7) has a lot of fixes compared to the 1.2.0 that's described here. Make sure you update both the Pymakr plugin as well as the firmware if you're facing issues. If that doesn't help, try to do a safe-boot before uploading. If that doesn't help, let me know and we'll debug further!

    Sidenote: the next Pymakr release will do an automatic safeboot for the upload feature.

  • I'm also having this issue. Any updates?

  • My solution was to go back to the previous 1.1.0 version:

    • removed the package (through prefs or to remove ~/.atom/packages/pymakr
    • installed the 1.1.0 version through apm on the console: apm install pymakr@1.1.0

  • @xykon thanks! I was using ftp all along, but wondered if I did something wrong. BTW: rshell works also, with the -a option (in case the ftp servers is not running on the ESP32).

  • administrators

    @ttmetro said in pymakr: Upload failed.:

    Any suggestions for diagnosing or fixing this?

    We are aware of the issue and are working on a solution. I suggest you try uploading all the files via ftp including the project.pymakr file if it exists and then try syncing your project again. If you continue to experience sync issues after the initial upload then unfortunately you'll have to use the ftp method until we managed to fix the issue.

Log in to reply

Pycom on Twitter