Can no longer type in the REPL area on Atom or connect to Lopy/Pytrack



  • Hello,

    I am not sure what I managed to do, I had established a connected and finally received GPS coordinates this morning. I saw the update for 1.10.0.b1 and installed it as earlier. Now I can't seem to connect and I also can't type anything in the command/REPL/bottom area of REPL. When I try to upload or download i get failed to connect (couldn't recreate for picture). This is what happens when I am in Atom with the Pytrack/LoPy connect, I can't seem to stop it or type.
    0_1510149224431_41ab9707-23a9-4039-ac16-6ecdef540739-image.png

    Does anyone have any ideas what I may have done, or know how to try again, I've tried on different computers so it seems to be something on the chip.

    Cheers,
    Dylan



  • @dylan the memory problem is not useful for your issue. You get them somethimes with older firmwares. The GPS part uses a lot of strings. The garbage collector seems to handle them not always in a proper way. But I never ran into this issue when the LoPy got only power over USB. Maybe I was only lucky, or a watchdog solved it for me.



  • @dylan
    It seems for some reasons you board was auonatically running some GPS script and the downgrade process probably wiped your boot.py/main.py. You should be able to upgrade again now.

    Next time you can try the safe boot procedure: https://docs.pycom.io/chapter/toolsandfeatures/bootmodes.html this will skip the boot scripts.



  • Problem was solved by following these steps:
    https://forum.pycom.io/topic/517/downgrading-firmware-advanced-users



  • I had an error come up again with possibly useful information:
    0_1510189164611_36242479-b77b-48aa-a9c8-91908081df9b-image.png

    I have been trying to connect through PuTTy and filezilla as well but unable to get a connection, I believe last time when I had trouble connecting to the LoPy after updating to DFU stuff for the Pytrack, I installed the USB serial (CDC) with zadiq and it connected. I redid the Pytrack stuff and attempted to re-install the USB serial (CDC) drivers but it failed and I'm not sure why. I'm trying to compile all my mistakes and successes as I need to write instructions to setup multiple units, so hopefully I'll be able to repay the help I'm getting here.

    Cheers,

    Dylan



  • @jcaron That sounds like a good plan, I'll have a google to try and figure out how to connect etc, but while your around, you dont happen to know where I can find instructions on erasing the flash/connecting via wifi to remove the boot.py/main.py.

    Cheers for the help.



  • @dylan can you connect to it via Wi-Fi? In that case try to remove or change your boot.py or main.py which seem to be stuck in a loop.

    You could also erase the flash or use one of the safe boot modes.



  • Yup, went through all the commands that are supposed to interrupt the currently running code



  • @dylan Have you tried Ctrl-C?


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.