Suddenly no USBconnection to any of my LoPy boards...



  • My LoPy's (4 of them) have been running just fine for almost a month!! All of sudden, my mac laptop (the same as I've been using all the time) suddenly won't recognize any of the lopy's (no os or other updates installed recently) when clicking "get serial ports". It just shows me "/dev/cu.lpss-serial12 (copied to clipboard)" which it will also show me when it's not plugged in.

    The only thing I can come up with that I did is using another board called Bela yesterday evening on the USB port. I tried rebooting several times already, and using different usb cables without luck.

    Could an automatic pymakr update have broken this somehow, or?

    In my hardware overview, the Lopy's are detected as "FT230X basic UART" with FTDI as manfuactorer..

    EDIT:
    after a 4th pc restart, it now shows up as "/dev/cu.usbserial-DO0036U4" but will still not connect. Just says connection timed out.

    EDIT II:
    Also, can someone tell me why I have to click "Open config folder" in global settings of the pymakr plugin, every single time I change to a different lopy.. thus having to close fans in the old window, and remove the default project and open my real work project. oh. my. god.

    Best


 

Pycom on Twitter