LoPy Lora issue connecting to Multitech conduit



  • Hello,

    I'm having a trouble setting up LoPy with Multitech conduit, I'm not trying to do anything complex yet. I'm just using the example in the link below with the EUI and Key matched between LoPy and Multi Tech as in the pictures. But I keep getting Not yet joined when I run the script... I tried different keys but that didn't make a difference and I do have a LoRa antenna connected to LoPy. Any Guidance would be much much appreciated. Thanks

    https://docs.pycom.io/chapter/tutorials/lopy/lorawan-otaa.html

    create an OTAA authentication parameters

    app_eui = binascii.unhexlify('00 00 00 00 00 00 00 00'.replace(' ',''))
    app_key = binascii.unhexlify('00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00'.replace(' ',''))

    0_1512769528490_d0ea6a5d-a405-404a-b24b-c4e81a541def-image.png

    0_1512769553262_4f5ce139-4e74-4a35-ada6-c07cb40c35ef-image.png



  • a) Yes, 2nd pin and 4th pin on the other side and are clearly labeled GND and G23
    b) Yes, I'm using the same COM port with TeraTerm to run a script... So it must be the right one



  • Hello!
    When you define de app_eui and app_key dont use "-" ... For example:

    app_eui = 0000000000000000;
    app_key = 00000000000000000000000000000000;

    So, in the lopy script define as it:

    app_eui = binascii.unhexlify('0000000000000000')
    app_key = binascii.unhexlify('00000000000000000000000000000000')

    Don't forget to define LoRa objet as Public like this:

    lora = Lora(mode = LoRa.LORAWAN, adr = True, Public = True)

    In my case that works ok!

    When you get join LoRa network, Could you post in this forum how much communication distance do you get? I don't achieved more than 800 meters in urban environment with SF7 or SF12.


 

Pycom on Twitter