Fresh FiPy - getting hot?! FW update (1.11.0.b1) not working...



  • Hi,
    just got my 2 FiPys today and was happy that a recent announcement made the FW update available also to FiPy. However, the FW update could not detect PyTrack/PySense and failed. After a few minutes more futile trying, I noticed that the FiPy got very hot to the touch - for the FW update I did not attach any antenna...
    Is this supposed to happen?
    Or was my FiPy just a bit too eager to get started? =)

    As I'd like to try them out, I'm glad for any help!

    Best,
    T.



  • @xykon Thanks Xykon. Yes, I connected a wire between 23 and GND before plugging it in and flashing.

    I think if there are thermal issues affecting all Fipys and its a known issue you should slap a sticky note or something on the site. I mean all the Fipys just went out recently. t.pirk and myself can't be the only ones noticing this.

    Should we not use the Fipys until a fix is available? I don't want to damage my units.


  • administrators

    @duhmojo We are aware that the FiPy modules can get quite warm... we are waiting for Sequans to provide a new firmware with better power & thermal management.

    Did you install the jumper wire and press the reset button before trying the upgrade in the Expansion Board?



  • Same here. I started playing with my FiPy's last night and I'm finding that they get quite hot, like super hot compared to my Lopys and Wipys, which can run non-stop and barely generate any heat. I'm using the latest everything as of today (Jan 4, 2018).

    Here's my details:
    Dev OS: MacOS
    Fipy firmware: 1.12.0.b1
    PySense firmware: 0.0.8 (dfu installed)
    PyTrack firmware: 0.0.8 (dfu installed)

    When I USB tether either of my Fipys it they start to warm up within 5 seconds it clearly warm to the touch. After a couple of minutes its hot. After an hour it doesn't melt down but its really hot.

    I've tried both the PySense, PyTrack and Expansion boards. The Fipys all are hot.

    The USB cables are fine. I have a collection and I can tether all manner of things, including my Lopys which don't heat up.

    FYI, I noticed that you can't flash the Fipy using the Expansion board. It'll only flash with the PySense or PyTrack boards. When I try I get the dreaded "Can't figure out if this is a PySense/PyTrack. Connecting.... Failure!" When I select the Expansion board + Fipy USB device the PySense/PyTrack checkbox is already off. I then click through and end up with the failure. Not sure if Pycom is carrying newer Expansion boards that work. Either this is a bug, or a really inconvenient over sight for anyone ordering just the Fipy and Expansion board. (ugh)


  • administrators

    From the error message I can see that the firmware update tool isn't able to connect to the FiPy. But since you were able to see general output from the module over serial means that the serial communication is working in general.

    I suggest you check three things:

    Make sure that no other program (Putty, Atom, Visual Studio Code) is open and using the COM port.

    Make sure you have at least Version 0.6 of the Pytrack / Pysense firmware installed.

    Make sure you select the checkbox for Pytrack/Pysense manually when selecting the com port in the firmware update tool.



  • @xykon Output on serial:
    rst:0x1 (POWERON_RESET),boot:0x16 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff9028,len:8
    load:0x3fff9030,len:1076
    load:0x4009fa00,len:0
    ho 12 tail 0 room 4
    load:0x4009fa00,len:15344
    entry 0x400a070c
    MicroPython v1.8.6-834-g5677703c on 2017-11-13; FiPy with ESP32
    Type "help()" for more information.



  • Thanks for the feedback and sorry for missing info... =)
    I'm with Win 10 and have now tried both FiPys, one in PyTrack, one in PySense (glad I backed the combo =) - and with two different USB cables. Unfortunately the problem persists:
    0_1513778747889_f43f16e0-d8f7-4d84-a8a7-8d4b6b200a7a-grafik.png

    Win 10 had no problem to assign COM ports to both boards, though.
    ...and the blue heartbeat was there from start, too.



  • If it not listed as a COM device, check if the dfu driver is installed. On my win7 I had to deinstall the dfu driver after every uptdate of pytrack, otherwise the pytrack was listed for a few seconds as a dfu device before it disapeared from the device manager.

    I am still on 1.10.x and 0.0.7 so it may not solve your problem, but worth a try.



  • @misterlisty Since the USB/UART bridge is located on the pysense to pytrack board, connecting these boards alone w/o a xxPy attached to it should already create the appropriate COM port. If you, there is a Windows driver issue.


  • administrators

    @misterlisty The Windows 7 driver for Pytrack & Pysense is found here: https://docs.pycom.io/chapter/pytrackpysense/installation/drivers.html



  • When i plug in a fipy connected to pytrack or pysense...should it create a COM port?



  • Where should windows downloads the pycom drivers from? I see Pysense in the oTher devices section of harwdare



  • @t-pirk The FiPy should have already an image loaded, which will make the heartbeat LED blink every few seconds. Did you see that?
    Are you sure you've placed the FiPy into the board in the right orientation?



  • I have the same issue on windows 7..not detected the fipy. I saw it try to install the pytrack drivers but then disappaered for ever..not COM ports created


  • administrators

    Could you please indicate which OS you are using?

    Have you tried a different USB cable?

    Do you get any output from the module over the serial port? when pressing the reset button?



Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.