Testing deepsleep on FyPi



  • Hi all,

    I can't seem to get power draw down on the new FiPy. I'm running v1.11.0.b1 firmware. Activating machine.deepsleep does drop power consumption but it continues to draw almost 150mA. Bare board, 5V input from bench power supply. If I use the expansion board with my inline USB power meter, the figures are the same (with an additional ~16mA for the expansion board power LED etc).

    What do I need to turn off to power this thing down? WLAN deinit drops about 70mA but that then comes off the deepsleep savings so I end up at the same 150mA.

    Obviously I'm missing something here!

    Also odd: Once I init LTE, even after deinit there is a net 30mA gain in power draw.



  • @jmarcelino Thanks, I look forward to it!



  • @incognico
    This was already addressed in an internal build, we will release it very soon.



  • @jmarcelino I posted in the linked thread but that has been ignored. Another firmware version released, another disappointing deepsleep() test.

    (sysname='FiPy', nodename='FiPy', release='1.14.0.b1', version='v1.8.6-849-86da809 on 2018-01-17', machine='FiPy with ESP32', lorawan='1.0.0', sigfox='1.0.1')

    Still seeing ~150mA in "deepsleep" :(

    Am I seeing different results than everyone else? Or is this typical for the FiPy at the moment?



  • @incognico
    Thank you for the observations.
    I'm looking into this and will have a solution shortly, as you found it's related to the LTE module power modes. More information here: https://forum.pycom.io/post/13781


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter