Pytrack + FiPy setup on Win7



  • Hi,
    I'm trying to install the Pytrack firmware as a first step to getting my new FiPy up and running. I followed the instructions from https://docs.pycom.io/chapter/pytrackpysense/installation/firmware.html

    Using Zadig, I got the firmware driver installed - 0_1514154338768_install_driver.png .

    However, when I later try to dfu-util to install the firmware, I get the below error:

    C:\Users\Sandip\Downloads>dfu-util-static.exe -D pytrack_0.0.8.dfu
    dfu-util 0.8

    Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
    Copyright 2010-2014 Tormod Volden and Stefan Schmidt
    This program is Free Software and has ABSOLUTELY NO WARRANTY
    Please report bugs to dfu-util@lists.gnumonks.org

    Match vendor ID from file: 04d8
    Match product ID from file: f014
    Cannot open DFU device 04d8:f014
    No DFU capable USB device available

    I am on Win 7.

    Thanks in advance for your assistance!

    ~Sandip



  • @seb

    A) FiPy+PyTrack+LiPo-Battery (Not-Attached-to-USB3.0)

    Vin = 4.09~4.10 V
    3V3 = 3.32 V

    B) PyTrack+USB-Serial-device (Attached-to—USB3.0)

    • same port as A)

    Vin = 4.85 V
    3V3 = 0.23 V

    C) PyTrack+USB-Serial-device (Attached-to—USB3.0) + Hotswap-in-FiPy

    • same port as A) & B)

    Vin = 4.55 V
    3V3 = 3.32 V

    D) PyTrack+FiPy+NO-USB-Serial-device (Attached-to—USB3.0)

    • same port as A) & B) & C)
    • same combo as C)
    • Just unplugged USB from PyTrack, and re-attached it…

    Vin = 1.69~2.51 V
    3V3 = 1.15~1.91 V

    • Also, worth nothing is that if my hand slips with the measuring probes, I get it to “boot-up” by accidentally shorting GROUND & 3V3, and I get a USB-Serial-Devices on my computer [ergo like A), B) & C) …] …
    • And then, I get the same Vin & 3V3 as C)
    • Which makes me conclude that you’ve guys have a Firmware issue!!! … and not a “bad usb-cable” or “bad usb-port” … etc etc.
    • For some reason, in the boot-sequence of the PyTrack Firmware, it choose not to boot-up FiPy and enable USB-Serial …
    • And, again, it’s odd that I can short GROUND & 3V3 with my measuring probes, and then it boots up FiPy and enables USB-Serial…


  • @combaindeft

    Could you try measuring Vin and 3.3 of the FiPy + Pytrack combo that does not show the USB serial? We have had a few customers facing issues that are fixed by using a high quality usb cable that can deliver enough current, the fact it works with a battery suggests this could be the issue.

    As for the code for the pytrack/pysense, at the current time we have not made this open source. This may be something that happens in the future but I can't give any more details at this time.



  • @jmarcelino

    I also just tried it with a JST LiPo Battery (FiPy+PyTrack+Lipo-Battery combo) ... and now it boots up and I get a usb-serial...

    So the odd thing is, why does it try to boot-up in DFU-mode when FiPy+PyTrack is connected?

    But it boots as usb-serial-device when only the Pytrack is connected? or when adding a battery, FiPy+PyTrack+Battery ...

    I find this a little bit of strange logic ... and It's a little bit odd ... and I do think there is some sort of issue in the Firmware code (pytrack_0.0.8.dfu)

    Where might one find the Firmware code (pytrack_0.0.8.dfu)? ... so one might have an investigative look at boot sequence of the PyTrack :-)



  • @jmarcelino

    Hi, I'm on a Mac and I to experience the "no FiPy device is detected when I connect the Pytack+Fipy via USB to the computer" ...

    I've done the installation procedure before on a LoPy+PyTrack combination ... and it worked like a charm.

    But when I try now with the FiPy+PyTrack combo ... I don't get a usb-serial connection ...

    The only way I can get it work is:

    1st) Connect only the PyTrack to usb
    2nd) I get a usb-serial device
    3rd) I then plug the FiPy device into the PyTrack ...
    4th) Now I see the FiPy boot up and run the "pycom.heartbeat(True)" ... Led blinking blue ...

    To re-cap, if I try to power on the FiPy+Track (combo) via usb, it doesn't even boot up (no Led blinking blue) ...



  • @sandipg Make sure you have the device in DFU mode...
    I tryied this many times sometimes It took me like 10 try to get the code in... also make sure you are in the right folder but it looks like you are in the right folder...

    =======================================

    Using DFU-util with Pytrack and Pysense
    In order to put Pyrack or Pysense in DFU mode, press and hold the button on the Pytrack/Pysense board whilst powering on the board (connecting the USB cable).
    Press the button and keep it held
    Next plug-in the USB cable to the host computer and wait 1 second before releasing the button.
    After this you will have approximately 7 seconds to run the DFU-util tool. -> This step you might have to do many times for it to work...

    https://docs.pycom.io/chapter/pytrackpysense/installation/firmware.html



  • @sat Yes it worked when I used the drivers provided by @jmarcelino



  • @sandipg Did this work for you?

    I am having the same issue. PyTrack is seen as a COM device. However, we I add the FiPy module to PyTrack I cannot see it as a COM device.



  • @jmarcelino Yes it is plugged in correctly. All the pins are fit snugly.



  • @crumble
    Really appreciate you trying to help but in this case @sandipg already seen the Pytrack as a COM port device, it's just when he tries with the FiPy.

    Also there is no need to remove the DFU driver as it's very convenient to have it for future upgrade. I can assure you it works without doing so, the DFU driver expects a different USB ID which only active when you press the button.

    So please don't remove the DFU driver that is not really a valid long term solution. Perhaps it worked for you in a specific case, maybe if you used Zadig it set the regular device with the wrong driver, but if you use the drivers I posted below this should not happen.



  • @sandipg

    How do I proceed?

    Your pytrack is still deteced as an dfu and not com device. The dfu device will be visible only for 7 seconds. Open device manager, pug out pytrack, plug in again. If you see your device pop up as a dfu device:

    • open the device manger
    • select show all devices (or be really quick, the device will be visible for 7 seonds)
    • open dfu devices
    • right click on the pytrack device
    • select properties/details/drivers
    • click on deinstall


  • @sandipg
    Sorry for all basic question but can I ask if the FiPy is plugged the right way around (with the LED and reset button on top of the Pytrack USB connector) and all pins are correctly seated?



  • @jmarcelino Thanks again.

    It works well until Step 3. With the FiPy on, Win 7 fails to detect the board (no COM port is visible). When I unplug the FiPy and connect just the PyTrack board, I can see the COM port. To double check if the firmware is still installed, I ran Zadig with just the PyTrack connected and this time it shows the driver installed.

    So now the problem is that when the FiPy is connected to PyTrack, Win7 fails to detect the board (no COM port is visible).

    How do I proceed?



  • @jmarcelino If you are working on a HowTo, add this, please:

    If your Pytrack is not detected on Windows 7 as a COM device after a pytrack firmware update, deinstall the dfu drive.

    If you are from spain an like to give us the Windows users a xmas gift, you still have some days to set up a minimalistic linux or *BSD virtual machine with all needed drivers for pytrack/pysense updates. Booting a VM is much easier than doing all this strange dfu driver Voodoo on windows.



  • @sandipg
    Thank you for your patience, I do realise this can be confusing. The correct order for Windows 7 should be:

    1. Update Pytrack firmware

    2. Install Windows 7 drivers for Pytrack

    You should have a new COM port on Device Manager at this point.

    1. Unplug the devices. Physically put the Fipy onto the Pytrack and plug back into your USB port

    2. Install and run the Pycom Firmware Updater (which currently only updates the the FiPy, LoPy, etc it doesn't update expansion boards like the Pytrack/Pysense)

    3. Select the COM port which appeared in step 2



  • Thanks @jmarcelino .

    I'd like to know the general order of installation: First I updated the firmware on the PyTrack, followed by the same on the FiPy as described in https://docs.pycom.io/chapter/gettingstarted/installation/firmwaretool.html#second

    Is this the right way?

    Or do I need to follow the steps in Section 4.2 and install also the software/libraries on the PyTrack before moving on to the FiPy?

    Whenever I follow the first option (as laid out in Ch 1), I cannot see the COM port of the PyTrack+FiPy when I run the Pycom Firmware Update tool. (Even after installing the Win 7 driver)

    Has anyone managed to get PyTrack + FiPy running in Windows? If yes, please share what you did.

    Thanks!



  • @sandipg
    Thanks, I think you may be missing the Windows 7 drivers?

    Please follow the steps at:
    https://docs.pycom.io/chapter/pytrackpysense/installation/drivers.html



  • Here is the screenshot (The driver is missing)
    0_1514375278329_zadig.png



  • @sandipg
    Can you check if you have the right driver? Maybe it changed where it shouldn't.

    After connecting the Pytrack normally (don't press the button) run Zadig again, go to Options -> enable "List All Devices" then choose Pytrack from the drop down list.

    Should show something like this. If not please post what driver is show in the "Driver" box.

    0_1514372140351_Screen Shot 2017-12-27 at 10.54.11.png



  • Hi @jmarcelino ,

    Thanks for your response. When I proceed with the Firmware update, it fails due to no connections.

    First, I cannot see the COM port in the drop down list (no device is detected when I connect the Pytack+Fipy via USB to the computer):

    0_1514371555429_pycom_update_fail.png

    I select FiPy in the next Window, which leads to:

    0_1514371601582_pycom_update_fail2.png

    Please let me know how to get this up and running. Thanks!

    ~Sandip


 

Pycom on Twitter