[SOLVED]No downlink

  • I'm working with several Lopy. Some are configured as nodes, one is configured as single channel gateway. I'm on TTN.
    Firmware info is :
    nodename='LoPy', release='1.14.0.b1', version='v1.8.6-849-86da809 on 2018-01-17', machine='LoPy with ESP32', lorawan='1.0.0'

    I cannot join TTN : I can see in TTN console join request is received by my gateway, join accept is sent to node. But nodes does not join.
    So I tried ABP activation in order to check if it was a donwlink or a join problem. In ABP uplinks packets are received but downlink packets are never received. I can see from TTN console it is sent.
    Here is node code :

    s = socket.socket(socket.AF_LORA, socket.SOCK_RAW)
    # set the LoRaWAN data rate
    s.setsockopt(socket.SOL_LORA, socket.SO_DR, config.LORA_NODE_DR)
    # make the socket blocking
    i = 0
    while True :
        pkt = b'PKT #' + bytes([i])
        print('Sending:', pkt)
        i += 1
        rx, port = s.recvfrom(256)
        if rx:
            print('Received: {}, on port: {}'.format(rx, port))

    TTN gateway <-> TTN server communication is done using TCP with TTN server port 1700 for nanogateway using Semtech packet forwarder. On my network incoming UDP traffic is blocked. I have to add a rule to allow UDP traffic from TTN server.
    More info about this issue here

Pycom on Twitter