Failure using Firmware Update Tool on LOPY 1.0

  • I am trying to update the firmware on a Lopy 1.0 on a Pysense 1.0 board.
    I have the latest versions of the pysense firmware, and the Firmware Upgrade Tool and I am running the Update Tool on Linux.
    The Pysense firmware was upgraded without issue.
    The upgrade on the firmware upgrade tool failed with the error "Something Failed Trying to connect to the device".
    I have followed all the advice on this forum but still get the same error. I have performed this update in the past without error.
    Any help from the gentlemen at Pycom would be appreciated.

  • @andrethemac thanks for the advice, you saved me a lot of wasted time.
    I was able to use the Windows Pycom Upgrade Tool without any problems.

    It seems the Linux command line tool does not work.
    Can someone form Pycom confirm they have tested this? If so I will raise something in GitHub as it looks like a bug.

  • @philwilkinson I had the same problem on linux using the commandline tool, but the gui version did work without errrors (but it took some time (more than a three minutes)

  • @jcaron thanks for the advice,
    1-I double checked nothing is trying to access the serial port
    2-running os.uname() in the repl provides

    (sysname='LoPy', nodename='LoPy', release='1.12.0.b1', version='v1.8.6-849-fcbbfe3 on 2018-01-03', machine='LoPy with ESP32', lorawan='1.0.0')

    3- unfortunately the pysense is not looking good:

    import pysense
    Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
    AttributeError: 'module' object has no attribute 'read_fw_version'

    so instead I tried

    "from pycoproc import Pycoproc\n\n__version__ = '1.4.0'\n\nclass Pysense(Pycoproc):\n\n def init(self, i2c=None, sda='P22', scl='P21'):\n Pycoproc.init(self, i2c, sda, scl)\n"

  • @philwilkinson A few things to try:

    • make sure there’s nothing else trying to open the serial port (pymakr, screen...)
    • use the cli version and report its output
    • on the device, use pysense.read_fw_version() to check it was correctly updated. Sometimes the dfu-util tool reports success but the Pysense actually isn’t upgraded

  • Thanks for the advice @Thosch42 . However I use a very short USB cable. It also worked for the Pysense firmware upgrade and I have used it previously for the Lopy upgrades. I am worried this may be a firmware compatibility issue.

  • @philwilkinson
    Have you checked or changed your USB cable. I had a similar issue last week. And after I changed my cable (I worked with some month without any problems) to a shorter and brand new one, everything works well.


Log in to reply

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.