Fipy Firmware Upgrade Error

  • We are making test using the Pycom devices and we've managed to create a gateway and node using two Lopy's and sending the raw data to TheThingsNetwork.

    To do it in our region using 915 Mhz we update the firmware to both devices. Now we want to make it more portable since the Lopy's only have WIFI connection but at the moment we try to upgrade the firmware of our Fipy device using the Pycom firmware tool it doesn't recognize it, it says connection failed.

    I followed every step in the process, connecting the wires from G23 to GND and so on, proof of it is the Lopy's working but I am not able to upgrade the Fipy's firmware to 915Mhz.

    OS: Windows 10
    Device: Fipy
    Software: Pycom firmware tool

    0_1519929846709_WhatsApp Image 2018-03-01 at 12.43.33.jpeg

  • Thank you very much @livius @jmarcelino, I tried both solutions, what worked for me was to press the reset button for 3 seconds before scanning the board.

  • Hi Ruben,

    For the FiPy please remove the jumpers on the expansion board marked CTS and RTS.

    It should work then.

    ps: Also be avoid placing the Expansion Board on top conductive metal cases like the photo above :-)

  • @rubencg195
    Did you press reset button?

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.