What does a green LED after power up mean?



  • When I power up my LoPy4 in my circuit the RGB LED turns green and stays that way. When I press the reset button or execute machine.reset() in the REPL it restarts and the LED turns off.

    What can be the cause of this? It is rather difficult for me to check if individual pins are causing the issue, so I hope it can be narrowed down to a few pins that can cause this.



  • @sympatron OK. I do not know where I found that, and cannot see it in the sources either. The only thing I found in the comments to 1.17.3.b1 was to switch of the RGB led early. So maybe it lights up for other reasons. A transition on P2 may bring the LED on. But at least the fact, that it switched off indicates the normal boot being started.



  • I made some other tests, the ones I can make since I have no oscilloscope, desktop lab power supply, ...
    So LoPy4 + expansion board with three NiMH batteries.

    1. First connection to power up => green light and than normal heartbeat blue light
    2. connect power, disconnect for few seconds (5 -10 seconds) and than reconnect => no green light, than starts blue heartbeat
    3. connect power, disconnect for more than 10/15 seconds, reconnect => green light and than blue heartbeat.
      I suppose that internal capacitors discharge.

    Than tried with external FTDI without +3.3V connected to LoPy4.
    With machine.reset() or machine.deepsleep() there is no green ligth.
    My explanation, but I could be wrong, the capacitors should be fully charged.



  • Does this happen when coming out of deep sleep as well, or only on the initial device start?



  • @robert-hh But this would have to be implemented somewhere in the firmware and I did not find any trace of this.



  • @robert-hh Thanks! I never saw anything in the docs regarding the purpose of this green LED. If anyone can point to that, it would be appreciated.



  • @dws I use a 3 feet USB3 extension cable at a USB3 port, with a short adapter cable to Micro-USB. That works well. USB3 is rated at 900 mA.
    The FiPys I have also show green light for ashort while on boot. As far as I know, that's just the confirmation than an firmware Image with a valid signature was found; green light for taking off, so to speak.



  • @marcobenini Hopefully others here can give their opinion on why this happens. I think you are correct. I am going to purchase some high-quality USB cables for use with pycom and other micros, to avoid this in the future. If anyone here can recommend a brand of cable they like, please do.



  • @dws Yes, You are right, it should be a problem with power supply.
    I retested with a very short USB cable and now it works, but there is always an initial "green" light that lasts about a second (that does not happens with the LoPy).

    The longer USB, I tried before, is the best one I have, infact is the only one that arrives to have a stable conenction with another LoRa card I have (not PyCom).

    It looks like the initial current need of LoPy4 vs. LoPy is higher, or initial powerup sequence of LoRa module is different.

    Probably is brown-out detection that causes the initial green light, combined, maybe, that onboard capacitors doesn't arrive to deal with (too small or slow capacitors ?).



  • @marcobenini Did you try a high-current power supply instead of PC usb power? that solved it for me. Find a USB supply rated at perhaps 1A or more. I have a large USB battery that also works well.



  • LoPy4 + Expansion board 2.0 and nothing else connected. same problem.
    If I plug and unplug the USB to the pc, than the green light stays on and it not possible interaction with LoPy4.
    Pressing the reset button, than it works normally.
    Firmware: the latest stable version from link in documentation (1.17.3.b1).
    Same expansion board and USB cable with LoPy => no problem.



  • Me too, with the sporadic green LED on startup. Pressing the reset set button a few times will typically get past the issue, but its not a good thing. So far, I've only seen this on a Lopy4 on an Expansion Brd 2. Not yet seen on the Lopy4 on PyTrack.
    This with FW 1.17.3.b1.



  • @sympatron I'm having this happen as well. I re-formatted the internal drive. This appears to be a sporadic problem for me. Sometimes it's white, sometimes green, and then sometimes things work properly. It's totally random as I plug it in or unplug it. LoPy4 + Expansion board 2



  • @sympatron

    I will look into it, but I don't think it is an actual firmware feature, the only time I have seen the green LED is when connecting/disconnecting a cable to P2 for firmware upgrades.

    Can you try disconnecting the circuitry on P2 if possible, and see if the issue goes away?



  • @seb
    I have connected a microcontroller to P2 to be able to put it into bootloader mode without physical interaction.
    But it is currently uninitialized and should therefore stay in high impedance input mode.
    Additionally it is always the same color, which would be unusual for glitches.

    Is green even a standard color that is used in the firmware?
    I can't find it anywhere in the source.



  • @robert-hh Is that new on the LoPy 4 or something? I've never seen a spontaneous (i.e. not through a script) green LED at boot on a LoPy 1.



  • Do you have anything connected to P2? The RGB LED is connected to this and if you have something else happening on that pin it could be causing an issue.



  • @sympatron
    I had a similar issue too, and it was related to bad power supply.



  • @robert-hh But in my case it does not turn off. At least not after a few seconds. I will test tomorrow if it will turn off after a longer time period.



  • @sympatron The green LED turns up at every boot. AFAIK it tells that a firmware with a valid checksum was found. It should turn off after a second. I had too observed the phenomenon you describe, but now it's gone, no clue why.


 

Pycom on Twitter