FW Version & os.uname

  • Hi,
    Is there a way to determine which version of firmware maps to which version of MicroPython?

    I upgraded the LoPy's we use to the latest version and our LoRa sensors stopped communicating with the LoPy module. They were working fine before the upgrade.
    Here is our LoRa configuration (mode=LoRa.LORA, tx_power=13, bandwidth=LoRa.BW_125KHZ, frequency=868000000, coding_rate=LoRa.CODING_4_5, sf=7)

    We tried playing with other parameters (such as region, power_mode, tx_iq & rx_iq ), but none of them made any difference.

    We are using RFM95 modules on our sensors.

    The version that was working
    (sysname='LoPy', nodename='LoPy', release='1.0.0.b1', version='v1.8.6-237-g9d21f17 on 2016-12-15', machine='LoPy with ESP32')

    Is it possible to get that tar ball (LoPy_868-XXX.tar.gz) for this version? Deeply grateful for your help.


  • It’s probably a better option to try to make it work with the current version of the firmware, otherwise you may have issues down the road when you need something else added or fixed.

    What are your settings on your sensors? In which direction to you have traffic flowing?

  • @kumarbala 1.0.0.b1 is the version of the Lora stack. There is an old version of the downgrade page. In the lower section, there a links to images. If you copy the link and change the version number, you can also access other versions. But I did not find 1.8.6

  • @robert-hh Couple of days ago. We ordered 3 boards all of them had the same version 1.0.0b1 build data 15-12-2016

  • @kumarbala When did you receive the boards?

  • @robert-hh Unfortunately, none of them worked - they are not the version that was on the LoPy boards we received. Looks like we cant get the firmware that working. (sysname='LoPy', nodename='LoPy', release='1.0.0.b1', version='v1.8.6-237-g9d21f17 on 2016-12-15', machine='LoPy with ESP32')

    Looks like we need to find another platform unfortunately. We were excited about usig LoPy in our design :(

  • @kumarbala No, there is no direct link between the firmware version and the version of Micropython and the Lora firmware. The latter was changed between FW V1.15 and V1.16, but V1.16 still showed 1.0.0 for the LoRa stack. You have to load a few of these elder versions and see, how they respond. if you look here: https://github.com/pycom/pycom-micropython-sigfox/releases
    Then you have some explanations for the releases.

  • Thanks @robert-hh Highly appreciate your quick response. But I dont see a 1.0.0.b1 or the version that maps to v1.8.6-237-g9d21f17?

Log in to reply

Pycom on Twitter