REPL Prompt missing and no response after connection

  • I am using LoPy4 on a Pysense board and had it all working. I was using Atom successfully and uploading files no problem. I could also telnet to the device.

    I'm using MacOS 10.13.3
    I should add on first use I updated the Pysense firmware using 'dfu-util -D pysense_0.0.8.dfu' and then updated the LoPy4 firmware - it said it was updating to 1.17.3b1 (I assume this is the latest but can't find a list of release numbers anywhere).

    I have been testing LoRa using the example code in the docs to access LoRaWAN (OTAA) (unsuccessfully so far), and tried some web server examples using MicroWebSrv & MicroDNSSrv.

    At some stage the REPL console stopped responding. On Atom I could initiate a connection, the Atom connection window would say 'Connected' but in the console window, after 'Connecting on /dev/tty.usbmodemPY... there was no '>>>' prompt.

    The same happens with Telnet. I can log in ok, get the 'Help()' message, but no response after that.

    I have tried Ctrl-B, & Ctrl-D, etc with no response. I've tried entering a command (blind) but still no response.

    I have reloaded the firmware a few times.
    I have tried using battery only and connecting via telnet, same result.
    The Blue LED heartbeat flashing continues ok all through this.

    Any suggestions?

  • @robert-hh Thanks, that did it!

    I had to do the P12 to 3.3V for the 7-9s to load the factory firmware.
    I retested a firmware update and it went back to the unresponsive mode. So I then reformatted the /flash area by running:

    import os

    A firmware update then worked ok.
    Thanks again.

  • @brentoon You could try a safe boot. Connect P12 to 3.3V and push the reset button (next to the RGB LED). Safe boot ignores and on boot. Similar is trying Ctrl-F in the REPL prompt.
    To avoid all other dependencies with Atom and the pymakr plugin, connect via USB using a simple terminal emulator like screen. That should be available on OS X.

Pycom on Twitter