[Solved] Has someone got an idea what has happened to my Lopy4?

  • I have a few lopys on expansion boards an I can connect to them via visual studio REPL.

    For a day or so I cannot connect to the lopy4?
    I can update the firmware on the board, the blue led blinks, I have done a factory reset +3.3v to G28 and it does the correct series of led blinks for factory reset.

    links are all connected on the expansion board.

    What can it be?

  • This thing about the solid green light on a Lopy4. I've been seeing that also. For me it first occurred after about a week of uptime of the LoPy4. I assume that some unobserved fatal error occurred which resulted in a watchdog reset and then a solid green light scenario manifested itself on the reboot. I pressed the reset button about 3 or 4 times, each time getting the solid green light. The next press of the reset button was followed by a normal boot and normal, expected behaviour of running code. I can't see this being a power supply issue, or an issue with file-system corruption.

  • Thats a winner! that works, thanks Sebastian.

  • @optimho

    Once it boots with the jumper can you run the following in the REPL:

    import os

    This will format the device so it should be like a new one. Can you see if after this and a reset, it connects normally to putty? You should see a message like this:

    rst:0x1 (POWERON_RESET),boot:0x17 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    ho 12 tail 0 room 4
    entry 0x400a05e0

  • @seb I could not connect with putty initially, but again if I placed the jumper +3.3v to G28 and press the reset button, then I can connect?
    Is this starting to sound bad?

  • @optimho

    Can you try connecting with PuTTY instead of visual studio to try narrow down what's causing the issue here, is it a hardware issue or a pymakr issue. You will need to set the baud to 115200

  • @seb I am using windows 10. but I have had a development here, maybe you can add some light on this.
    I have just managed to connect, by plugging the Lopy4 into the USB, some times I get a green led solid - possibly power requirements on the usb?

    Then press the reset button (If the green LED is on)
    wait until the blue LED flashes
    then I jumper 3.3v to G28 and then
    Press the reset button and wait - three orange flashes .. ..... until the blue led is flashing steadily
    then I can connect .

    remove the jumper, check I am still connected.

    press reset try and connect again - no luck
    power down try and connect - no luck
    restart visual studio code and try and connect, just says 'connecting on com6.... ' and no luck?

  • @optimho

    Are you using windows, mac os or linux?

  • @seb thank you Sebastian, jumpers are tight and the LED is on the usb side.

  • @optimho

    Sounds like you have tried all the usual steps, just to clarify, you have made sure all the jumpers are correctly pushed in on the expansion board. Also is the module in the correct orientation?

Log in to reply

Pycom on Twitter